HDU 3161 Iterated Difference 暴力

Iterated Difference

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 786    Accepted Submission(s): 505

Problem Description You are given a list of N non-negative integers a(1), a(2), … , a(N). You replace the given list by a new list: the k-th entry of the new list is the absolute value of a(k) – a(k+1), wrapping around at the end of the list (the k-th entry of the new list is the absolute value of a(N) – a(1)). How many iterations of this replacement are needed to arrive at a list in which every entry is the same integer?

For example, let N = 4 and start with the list (0 2 5 11). The successive iterations are:

2 3 6 11

1 3 5 9

2 2 4 8

0 2 4 6

2 2 2 6

0 0 4 4

0 4 0 4

4 4 4 4

Thus, 8 iterations are needed in this example.  

 

Input The input will contain data for a number of test cases. For each case, there will be two lines of input. The first line will contain the integer N (2 <= N <= 20), the number of entries in the list. The second line will contain the list of integers, separated by one blank space. End of input will be indicated by N = 0.  

 

Output For each case, there will be one line of output, specifying the case number and the number of iterations, in the format shown in the sample output. If the list does not attain the desired form after 1000 iterations, print ‘not attained’.  

 

Sample Input 4 0 2 5 11 5 0 2 5 11 3 4 300 8600 9000 4000 16 12 20 3 7 8 10 44 50 12 200 300 7 8 10 44 50 3 1 1 1 4 0 4 0 4 0  

 

Sample Output Case 1: 8 iterations Case 2: not attained Case 3: 3 iterations Case 4: 50 iterations Case 5: 0 iterations Case 6: 1 iterations  

#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 100
const int inf=0x7fffffff;   //无限大
ll n[maxn];
ll n2[maxn];
int N;
int main()
{
    int cas=1;
    int N;
    while(cin>>N)
    {
        if(N==0)
            break;
        for(int i=0;i<N;i++)
        {
            cin>>n[i];
            n2[i]=n[i];
        }
        ll ans=0;
        int flag=0;
        int kiss=0;
        for(int i=0;i<N;i++)
        {
            if(n[i]!=n[(i+1)%N])
            {
                kiss=0;
                break;
            }
            if(i==N-1)
                kiss=1;
        }
        while(kiss==0&&ans<=1000)
        {

            for(int i=0;i<N;i++)
            {
                n[i]=fabs(n2[i]-n2[(i+1)%N]);
            }
            for(int i=0;i<N;i++)
            {
                n2[i]=n[i];
            }
            ans++;
            for(int i=0;i<N;i++)
            {
                if(n[i]!=n[(i+1)%N])
                {
                    kiss=0;
                    break;
                }
                if(i==N-1)
                    kiss=1;
            }
        }
        if(kiss==1)
            printf("Case %d: %d iterations\n",cas,ans);
        else
            printf("Case %d: not attained\n",cas);
        cas++;
    }
    return 0;
}

 

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4254708.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞