HDU 1698 just a hook 线段树,区间定值,求和

Just a Hook

Time Limit: 1 Sec  Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=1698

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3


Sample Output

Case 1: The total value of the hook is 24.

HINT

题意

 

区间更新为定值,然后问你区间和为多少

 

题解:

 

啊,线段树加懒操作,套版

 

代码:

 

#include <stdio.h>
#include <string.h>

const int MAXN = 100010;
int sum[MAXN<<2];
int lazy[MAXN<<2];

void pushup(int rt)
{
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void pushdown(int rt, int x)
{
    if(lazy[rt] != -1) {
        lazy[rt<<1] = lazy[rt<<1|1] = lazy[rt];
        sum[rt<<1] = (x-(x>>1))*lazy[rt];///!!!
        sum[rt<<1|1] = (x>>1)*lazy[rt];///!!!
        lazy[rt] = -1;
    }
}

void creat(int l, int r, int rt)
{
    lazy[rt] = -1, sum[rt] = 1;
    if(l == r) return;
    int mid = (l+r)>>1;
    creat(l, mid, rt<<1);
    creat(mid+1, r, rt<<1|1);
    pushup(rt);
}

void modify(int l, int r, int x, int L, int R, int rt)
{
    if(l <= L && r >= R) {
        lazy[rt] = x;
        sum[rt] = x*(R-L+1);///!!!
        return;
    }
    pushdown(rt, R-L+1);///!!!
    int mid = (L+R)>>1;
    if(l <= mid) modify(l, r, x, L, mid, rt<<1);
    if(r > mid) modify(l, r, x, mid+1, R, rt<<1|1);
    pushup(rt);
}

int main()
{
    int i, j, k = 0;
    int n, T, q;
    int x, y, w;
    while(scanf("%d", &T) != EOF)
    while(T--)
    {
        scanf("%d %d", &n, &q);
        creat(1, n, 1);

        while(q--) {
            scanf("%d %d %d", &x, &y, &w);
            modify(x, y, w, 1, n, 1);
        }

        printf("Case %d: The total value of the hook is %d.\n", ++k, sum[1]);
    }
    return 0;
}

 

,

Just a Hook

Time Limit: 1 Sec  Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=1698

Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3


Sample Output

Case 1: The total value of the hook is 24.

HINT

题意

 

区间更新为定值,然后问你区间和为多少

 

题解:

 

啊,线段树加懒操作,套版

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4396606.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞