HDU 3974 Assign the task 并查集/图论/线段树

Assign the task

Time Limit: 1 Sec  Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=3974

Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N – 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

“T x y”which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
 C 3
T 3 2
C 3

 

Sample Output

Case #1: -1 1 2

 

HINT

 

题意

给你一个森林,有两个操作

1.让某一个点,和他的儿子们全部染成X

2.查询某一个点是什么权值

 

题解:

当成单纯的图论跑一发就好,对于每一个查询直接跑到根位置就好,更新的时候,注意更新的时间问题

线段树也可以做,把一颗树的,全部放在一起,然后就区间更新就好,对于每一个点,记录他的位置,和他儿子最远能到哪儿。

代码:

 

//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define maxn 200001
#define mod 10007
#define eps 1e-9
int Num;
char CH[20];
//const int inf=0x7fffffff;   //нчоч╢С
const int inf=0x3f3f3f3f;
/*

inline void P(int x)
{
    Num=0;if(!x){putchar('0');puts("");return;}
    while(x>0)CH[++Num]=x%10,x/=10;
    while(Num)putchar(CH[Num--]+48);
    puts("");
}
*/
//**************************************************************************************
inline ll read()
{
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
inline void P(int x)
{
    Num=0;if(!x){putchar('0');puts("");return;}
    while(x>0)CH[++Num]=x%10,x/=10;
    while(Num)putchar(CH[Num--]+48);
    puts("");
}
struct node
{
    int x,y;
}a[maxn];
int pa[maxn];
int main()
{
    char s[10];
    int b,c;
    int t=read();
    for(int cas=1;cas<=t;cas++)
    {
        int n=read();
        memset(a,0,sizeof(a));
        memset(pa,-1,sizeof(pa));
        for(int i=0;i<n-1;i++)
        {
            int u=read(),v=read();
            pa[u]=v;
        }
        for(int i=0;i<=n;i++)
        {
            a[i].x=-1;
            a[i].y=-1;
        }
        int m=read();
        printf("Case #%d:\n",cas);
        int co=0;
        for(int i=0;i<m;i++)
        {
            scanf("%s",s);
            if(s[0]=='C')
            {
                b=read();
                int k=a[b].x;
                int y=a[b].y;
                while(b!=-1)
                {
                    if(a[b].y>y)
                    {
                        k=a[b].x;
                        y=a[b].y;
                    }
                    b=pa[b];
                }
                printf("%d\n",k);
            }
            else
            {
                b=read(),c=read();
                a[b].x=c;
                a[b].y=++co;
            }
        }
    }
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4448918.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞