Hdu 5444 Elven Postman dfs

Elven Postman

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5444

Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input

First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,…,an where a1,…,an∈{1,…,n}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,…,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1

Sample Output

E

WE
EEEEE

 

HINT

 

题意

建树;编号是这棵树从右往左进行编号的,越往右边的编号越小

给你一个数组,然后问你走到一些点,究竟该怎么走

题解:

注意,树的形态是唯一的

我们可以处理每个节点能够放的点的大小的范围,然后就可以求出这棵树的样子了

回答就可以顺便再DFS建树的过程中处理出来

赛后听人说,这是先序遍历/中序遍历?

非计算机专业完全不懂= =

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stack>
#include <map>
#include <set>
#include <queue>
#include <iomanip>
#include <string>
#include <ctime>
#include <list>
#include <bitset>
typedef unsigned char byte;
#define pb push_back
#define input_fast std::ios::sync_with_stdio(false);std::cin.tie(0)
#define local freopen("in.txt","r",stdin)
#define pi acos(-1)

using namespace std;
struct node
{
    int L , R ;
    string str;     
};

const int maxn = 1e3 + 15;
int n , p[maxn] , q , ctt = 2 ;
vector<int>qq;
node c[maxn];

bool dfs(int u)
{
/*    cout << "u is " << u << endl;
    cout << "ctt is " << ctt << endl;
    getch();*/
    if(ctt == n + 1) return true; 
    while(1)
    {
       if(c[u].L <= p[ctt] && p[ctt] <= c[u].R)
      {
        int x = p[ctt];
        int y = u;
        if(x < y)
        {
            c[x].str = c[u].str + 'E';
            c[x].R = y;
            c[x].L = c[u].L;
        }
        else
        {
            c[x].str = c[u].str + 'W';
            c[x].L = y;
            c[x].R = c[u].R;
        }
        ctt++;
        if(ctt == n + 1) return true; 
        if(dfs(x)) return true;
      }
      else
       return false; 
      if(ctt == n + 1) return true; 
    }
}

void initiation()
{
    qq.clear();
    scanf("%d",&n);
    for(int i = 1 ; i <= n ; ++ i) scanf("%d",p + i);
    scanf("%d",&q);
    for(int i = 1 ; i <= q;  ++ i)
    {
        int x;
        scanf("%d",&x);
        qq.push_back(x);
    }
    for(int i = 1 ; i <= n ; ++ i)
    {
        c[i].str = "";
        c[i].L = -10000 , c[i].R = 10000;
    }
    ctt = 2;
    dfs(p[1]);
}

void solve()
{
    for(int i = 0 ; i < q ;++ i) cout << c[qq[i]].str << endl;
}


int main(int argc,char *argv[])
{
    //freopen("out.txt","w",stdout);
    int Case;
    scanf("%d",&Case);
    while(Case--)
    {
        initiation();
        solve();
    }
    return 0;
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4805305.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞