hdu 5495 LCS 水题

LCS

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5495

Description

你有两个序列\{a_1,a_2,...,a_n\}{a1​​,a2​​,...,an​​}和\{b_1,b_2,...,b_n\}{b1​​,b2​​,...,bn​​}. 他们都是11到nn的一个排列. 你需要找到另一个排列\{p_1,p_2,...,p_n\}{p1​​,p2​​,...,pn​​}, 使得序列\{a_{p_1},a_{p_2},...,a_{p_n}\}{ap1​​​​,ap2​​​​,...,apn​​​​}和\{b_{p_1},b_{p_2},...,b_{p_n}\}{bp1​​​​,bp2​​​​,...,bpn​​​​}的最长公共子序列的长度最大.

Input

输入有多组数据, 第一行有一个整数TT表示测试数据的组数. 对于每组数据: 第一行包含一个整数n (1 \le n \le 10^5)n(1n105​​), 表示排列的长度. 第2行包含nn个整数a_1,a_2,...,a_na1​​,a2​​,...,an​​. 第3行包含nn个整数 b_1,b_2,...,b_nb1​​,b2​​,...,bn​​. 数据中所有nn的和不超过2 \times 10^62×106​​.

Output

对于每组数据, 输出LCS的长度.

Sample Input

2
3
1 2 3
3 2 1
6
1 5 3 2 6 4
3 6 2 4 5 1

Sample Output

2
4

HINT

 

题意

 

题解:

建边,a[i]->b[i]这样建边,对于其中构成的长度为l的环,我们能构造出长度为l-1的lcs

所以答案就是n-环的个数

代码:

#include<iostream>
#include<stdio.h>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;

int a[100500];
int b[100500];
int c[100500];
int vis[100500];
int main()
{
    int n;
    int t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            vis[i]=0;
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        for(int i=1;i<=n;i++)
            c[a[i]]=b[i];
        int ans = n;
        for(int i=1;i<=n;i++)
        {
            int x=i;
            if(vis[x])continue;
            if(c[x]!=x)
            {
                ans--;
                while(!vis[x])
                {
                    vis[x]=1;
                    x=c[x];
                }
            }
        }
        printf("%d\n",ans);
    }
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4854109.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞