HDU 5536 Chip Factory 字典树

Chip Factory

Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5536

Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Under two situations the player could score one point.


⋅1. If you touch a buoy before your opponent, you will get one point. For example if your opponent touch the buoy #2 before you after start, he will score one point. So when you touch the buoy #2, you won’t get any point. Meanwhile, you cannot touch buoy #3 or any other buoys before touching the buoy #2.

⋅2. Ignoring the buoys and relying on dogfighting to get point. If you and your opponent meet in the same position, you can try to fight with your opponent to score one point. For the proposal of game balance, two players are not allowed to fight before buoy #2 is touched by anybody.

There are three types of players.

Speeder: As a player specializing in high speed movement, he/she tries to avoid dogfighting while attempting to gain points by touching buoys.
Fighter: As a player specializing in dogfighting, he/she always tries to fight with the opponent to score points. Since a fighter is slower than a speeder, it’s difficult for him/her to score points by touching buoys when the opponent is a speeder.
All-Rounder: A balanced player between Fighter and Speeder.

There will be a training match between Asuka (All-Rounder) and Shion (Speeder).
Since the match is only a training match, the rules are simplified: the game will end after the buoy #1 is touched by anybody. Shion is a speed lover, and his strategy is very simple: touch buoy #2,#3,#4,#1 along the shortest path.

Asuka is good at dogfighting, so she will always score one point by dogfighting with Shion, and the opponent will be stunned for T seconds after dogfighting. Since Asuka is slower than Shion, she decides to fight with Shion for only one time during the match. It is also assumed that if Asuka and Shion touch the buoy in the same time, the point will be given to Asuka and Asuka could also fight with Shion at the buoy. We assume that in such scenario, the dogfighting must happen after the buoy is touched by Asuka or Shion.

The speed of Asuka is V1 m/s. The speed of Shion is V2 m/s. Is there any possibility for Asuka to win the match (to have higher score)?

Input

The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

 

Output

For each test case, please output an integer indicating the checksum number in a line.

 

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

HINT

 

题意

给你100组test,然后每组数据有1000个数,然后让你求(ai+aj)^ak的最大值,i!=j!=k

题解:

比较裸的字典树,写一个删除和添加操作就好了

代码

 

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
const int maxn = 1000 + 10;
const int maxnode = 100000 + 10;

int a[maxn];
int ch[maxnode][2];
int val[maxnode];
int sz;
void init()
{
    sz=1;
    memset(ch[0],0,sizeof(ch[0]));
    memset(val,0,sizeof(val));
}
void add(int x,int v)
{
    int p = 0;
    for(int i=31;i>=0;i--)
    {
        int id = (x>>i)&1;
        if(ch[p][id]==0)
        {
            memset(ch[sz],0,sizeof(ch[sz]));
            val[sz]=0;
            ch[p][id]=sz++;
        }
        p = ch[p][id];
        val[p]+=v;
    }
}
int match(int x)
{
    int ans = 0,u = 0;
    x = ~x;
    for(int i=31;i>=0;i--)
    {
        ans*=2;
        int id = (x>>i)&1;
        if(ch[u][id]&&val[ch[u][id]])
        {
            ans++;
            u = ch[u][id];
        }
        else
            u = ch[u][1-id];
    }
    return ans;
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        init();
        int n;scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
            add(a[i],1);
        int ans = 0;
        for(int i=1;i<=n;i++)
        {
            add(a[i],-1);
            for(int j=i+1;j<=n;j++)
            {
                add(a[j],-1);
                ans = max(ans,match(a[i]+a[j]));
                add(a[j],1);
            }
            add(a[i],1);
        }
        printf("%d\n",ans);
    }
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4955980.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞