hdu 5534 Partial Tree 背包DP

Partial Tree

Time Limit: 20 Sec

Memory Limit: 256 MB

题目连接

http://acm.hdu.edu.cn/showproblem.php?pid=5534

Description

In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has n nodes but lacks of n1 edges. You want to complete this tree by adding n1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?

Input

The first line contains an integer T indicating the total number of test cases.
Each test case starts with an integer n in one line,
then one line with n−1 integers f(1),f(2),…,f(n−1).

1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n>100.

Output

For each test case, please output the maximum coolness of the completed tree in one line.

Sample Input

2
3
2 1
4
5 1 4

Sample Output

5
19

HINT

 

题意

给你n个点,让你构造出一棵树

假设这棵树最后度数为k的点有num[k]个,那么这棵树的价值为sigma(num[i]*f[i])

其中f[i]是已经给定的

题解:

dp,我们首先给所有点都分配一个度数,那么还剩下n-2个度数没有分配

我们就可以dp了

dp[i]表示当前分配了i点度数时获得的最优值是多少,那么直接暴力转移就好了

背包DP

代码

#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int n;
int dp[2300];
int f[2300];
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n-1;i++)
            scanf("%d",&f[i]);
        for(int i=0;i<=n;i++)
            dp[i]=-9999999;
        dp[0]=n*f[0];
        for(int i=1;i<n-1;i++)
            f[i]-=f[0];
        n-=2;
        for(int i=1;i<=n;i++)
        {
            for(int j=i;j<=n;j++)
            {
                dp[j]=max(dp[j],dp[j-i]+f[i]);
            }
        }
        printf("%d\n",dp[n]);
    }
}

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4967071.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞