HDU 5294 Tricks Device 网络流 最短路

Tricks Device

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5294

Description

Innocent Wu follows Dumb Zhang into a ancient tomb. Innocent Wu’s at the entrance of the tomb while Dumb Zhang’s at the end of it. The tomb is made up of many chambers, the total number is N. And there are M channels connecting the chambers. Innocent Wu wants to catch up Dumb Zhang to find out the answers of some questions, however, it’s Dumb Zhang’s intention to keep Innocent Wu in the dark, to do which he has to stop Innocent Wu from getting him. Only via the original shortest ways from the entrance to the end of the tomb costs the minimum time, and that’s the only chance Innocent Wu can catch Dumb Zhang.
Unfortunately, Dumb Zhang masters the art of becoming invisible(奇门遁甲) and tricks devices of this tomb, he can cut off the connections between chambers by using them. Dumb Zhang wanders how many channels at least he has to cut to stop Innocent Wu. And Innocent Wu wants to know after how many channels at most Dumb Zhang cut off Innocent Wu still has the chance to catch Dumb Zhang.

Input

There are multiple test cases. Please process till EOF.
For each case,the first line must includes two integers, N(<=2000), M(<=60000). N is the total number of the chambers, M is the total number of the channels.
In the following M lines, every line must includes three numbers, and use ai、bi、li as channel i connecting chamber ai and bi(1<=ai,bi<=n), it costs li(0<li<=100) minute to pass channel i.
The entrance of the tomb is at the chamber one, the end of tomb is at the chamber N.

Output

Output two numbers to stand for the answers of Dumb Zhang and Innocent Wu’s questions.

Sample Input

8 9
1 2 2
2 3 2
2 4 1
3 5 3
4 5 4
5 8 1
1 6 2
6 7 5
7 8 1

Sample Output

2 6

Hint

题意

给一个无向图,然后问你最少删除多少个边使得最短路改变。

最多删除多少条边使得最短路仍然不变。

题解:

第一个问题,我们把所有最短路的边扔去跑最小割就好了。

第二个问题,跑一个dij然后除了最短的那条最短路以外,其他的边都删除就好了。

代码

#include <bits/stdc++.h>

using namespace std;
const int maxn = 2000 + 50;
struct edge{
    int v , nxt , w;
}e[60000 * 3];
struct node{
    int x , y , z;
    friend bool operator < (const node & a ,const node & b){
        return a.y > b.y || ( a.y == b.y && a.z > b.z );
    }
    node(int x = 0 ,int y = 0 , int z = 0) : x(x) , y(y) , z(z) {}
};
int n , m , head[maxn] , tot , flag[maxn];
pair < int , int > dp1[maxn] , dp2[maxn];
int E1[60000*2+5],E2[60000*2+5],E3[60000*2+5];

namespace NetFlow
{
    const int MAXN=100000,MAXM=1000000,inf=1e9;
    struct Edge
    {
        int v,c,f,nx;
        Edge() {}
        Edge(int v,int c,int f,int nx):v(v),c(c),f(f),nx(nx) {}
    } E[MAXM];
    int G[MAXN],cur[MAXN],pre[MAXN],dis[MAXN],gap[MAXN],N,sz;
    void init(int _n)
    {
        N=_n,sz=0; memset(G,-1,sizeof(G[0])*N);
    }
    void link(int u,int v,int c)
    {
        E[sz]=Edge(v,c,0,G[u]); G[u]=sz++;
        E[sz]=Edge(u,0,0,G[v]); G[v]=sz++;
    }
    bool bfs(int S,int T)
    {
        static int Q[MAXN]; memset(dis,-1,sizeof(dis[0])*N);
        dis[S]=0; Q[0]=S;
        for (int h=0,t=1,u,v,it;h<t;++h)
        {
            for (u=Q[h],it=G[u];~it;it=E[it].nx)
            {
                if (dis[v=E[it].v]==-1&&E[it].c>E[it].f)
                {
                    dis[v]=dis[u]+1; Q[t++]=v;
                }
            }
        }
        return dis[T]!=-1;
    }
    int dfs(int u,int T,int low)
    {
        if (u==T) return low;
        int ret=0,tmp,v;
        for (int &it=cur[u];~it&&ret<low;it=E[it].nx)
        {
            if (dis[v=E[it].v]==dis[u]+1&&E[it].c>E[it].f)
            {
                if (tmp=dfs(v,T,min(low-ret,E[it].c-E[it].f)))
                {
                    ret+=tmp; E[it].f+=tmp; E[it^1].f-=tmp;
                }
            }
        }
        if (!ret) dis[u]=-1; return ret;
    }
    int dinic(int S,int T)
    {
        int maxflow=0,tmp;
        while (bfs(S,T))
        {
            memcpy(cur,G,sizeof(G[0])*N);
            while (tmp=dfs(S,T,inf)) maxflow+=tmp;
        }
        return maxflow;
    }
}


using namespace NetFlow;

void My_init(){
    for(int i = 1 ; i <= n ; ++ i) head[i] = -1 , dp1[i].first = 1<<29 , dp2[i].first = 1<<29 , flag[i] = 0;
    tot = 0;
}

void Edge_link(int u , int v , int w){
    e[tot].v=v,e[tot].nxt=head[u],e[tot].w=w,head[u]=tot++;
}

void Dijkstra( int start , pair < int , int > * p ){
    priority_queue<node>Q;
    Q.push(node( start , 0 , 0 ));
    p[start]=make_pair(0,0);
    while(!Q.empty()){
        node S = Q.top() ; Q.pop();
        int x = S.x;
        pair < int , int > Ls = make_pair( S.y , S.z );
        if( Ls != p[x] ) continue;
        for(int i = head[x] ; ~i ; i = e[i].nxt){
            int v = e[i].v;
            int w = e[i].w;
            pair < int , int > newLs = make_pair( Ls.first + w , Ls.second + 1 );
            if( newLs.first < p[v].first || (newLs.first == p[v].first && newLs.second < p[v].second)){
                p[v] = newLs;
                Q.push( node( v , newLs.first , newLs.second ) );
            }
        }
    }
}

int main(int argc,char *argv[]){
    while( ~ scanf("%d%d" , &n , &m ) ){
        My_init();
        for(int i = 1 ; i <= m ; ++ i){
            int u , v , w;
            scanf("%d%d%d",&u,&v,&w);
            E1[i]=u,E2[i]=v,E3[i]=w;
            Edge_link( u , v , w );
            Edge_link( v , u , w );
        }
        Dijkstra( 1 , dp1 );
        Dijkstra( n , dp2 );
        int mincost = dp1[n].first;
        init( n + 4 );
        for(int i = 1 ; i <= m ; ++ i)
        {
            if(dp1[E1[i]].first + dp2[E2[i]].first + E3[i] == mincost)
                link(E1[i],E2[i],1);
            if(dp2[E1[i]].first + dp1[E2[i]].first + E3[i] == mincost)
                link(E2[i],E1[i],1);
        }
        printf("%d %d\n" , dinic( 1 , n ) , m - dp1[n].second );
    }
    return 0;
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5269586.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞