HDU 5640 King's Cake GCD

King’s Cake

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5640

Description

It is the king’s birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1≤n,m≤10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.

Input

The first line contains a number T(T≤1000), the number of the testcases.

For each testcase, the first line and the only line contains two positive numbers n,m(1≤n,m≤10000).

Output

For each testcase, print a single number as the answer.

Sample Input

2
2 3
2 5

Sample Output

3
4

hint:
For the first testcase you can divide the into one cake of \(2\times2\) , 2 cakes of \(1\times 1\)

Hint

题意

给一个n*m的矩形

你每次可以消去这个矩形中最大的正方形。

问你最多可以消去多少次。

题解:

像求GCD那样切就好了。

当然辗转相减法也是兹瓷的。

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;

int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int ans = 0;
        while(n&&m)
        {
            if(n>m)swap(n,m);
            m-=n;
            ans++;
        }
        cout<<ans<<endl;
    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5270308.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞