HDU 4611 Balls Rearrangement 数学

Balls Rearrangement

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=4611

Description

  Bob has N balls and A boxes. He numbers the balls from 0 to N-1, and numbers the boxes from 0 to A-1. To find the balls easily, he puts the ball numbered x into the box numbered a if x = a mod A. Some day Bob buys B new boxes, and he wants to rearrange the balls from the old boxes to the new boxes. The new boxes are numbered from 0 to B-1. After the rearrangement, the ball numbered x should be in the box number b if x = b mod B.
  This work may be very boring, so he wants to know the cost before the rearrangement. If he moves a ball from the old box numbered a to the new box numbered b, the cost he considered would be |a-b|. The total cost is the sum of the cost to move every ball, and it is what Bob is interested in now.
  

Input

The first line of the input is an integer T, the number of test cases.(0<T<=50)
  Then T test case followed. The only line of each test case are three integers N, A and B.(1<=N<=1000000000, 1<=A,B<=100000).
  

Output

For each test case, output the total cost.

Sample Input

3
1000000000 1 1
8 2 4
11 5 3

Sample Output

0
8
16

Hint

题意

有n个数,给你a和b

T1[i]=i%a,T2[i]=i%b

求sigma(T1[i]-T2[i])

题解:

简单思考一下,他们之间的差一开始都是0的,当遇到某个数是a的倍数的时候,他们之间每个数的差就会增加a,遇到某个数是b的倍数的时候,差就会减少b

根据这个去跑一个lcm周期的答案就好了

然后再暴力算最后一个n%lcm的答案就好了

代码

#include<bits/stdc++.h>
using namespace std;

long long gcd(long long a,long long b)
{
    if(b==0)return a;
    return gcd(b,a%b);
}
long long lcm(long long a,long long b)
{
    return a*b/gcd(a,b);
}
vector<long long>p;
void init()
{
    p.clear();
}
void solve()
{
    init();
    long long n,a,b;
    cin>>n>>a>>b;
    long long c = lcm(a,b);
    for(long long i=1;i*a<=c;p.push_back(i*a),i++);
    for(long long i=1;i*b<=c;p.push_back(i*b),i++);
    p.push_back(0);sort(p.begin(),p.end());p.erase(unique(p.begin(),p.end()),p.end());
    long long ans = 0,now = 0;
    for(int i=1;i<p.size()-1;i++)
    {
        if(p[i]%a==0)now-=a;
        if(p[i]%b==0)now+=b;
        ans+=abs(now)*(p[i+1]-p[i]);
    }
    long long k = n/c;
    long long Ans = 0;
    Ans = Ans + k*ans;
    k = n%c;
    int kkk = 0;
    for(int i=0;i<p.size()-1&&p[i+1]<k;i++)
    {
        kkk = i+1;
        if(p[i]%a==0)now-=a;
        if(p[i]%b==0)now+=b;
        Ans+=abs(now)*(p[i+1]-p[i]);
    }
    if(p[kkk]%a==0)now-=a;
    if(p[kkk]%b==0)now+=b;
    Ans+=abs(now)*(k-p[kkk]);
    cout<<Ans<<endl;
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)solve();
    return 0;
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5373566.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞