hdu 5723 Abandoned country 最小生成树 期望

Abandoned country

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5723

Description

An abandoned country has n(n≤100000) villages which are numbered from 1 to n. Since abandoned for a long time, the roads need to be re-built. There are m(m≤1000000) roads to be re-built, the length of each road is wi(wi≤1000000). Guaranteed that any two wi are different. The roads made all the villages connected directly or indirectly before destroyed. Every road will cost the same value of its length to rebuild. The king wants to use the minimum cost to make all the villages connected with each other directly or indirectly. After the roads are re-built, the king asks a men as messenger. The king will select any two different points as starting point or the destination with the same probability. Now the king asks you to tell him the minimum cost and the minimum expectations length the messenger will walk.

Input

The first line contains an integer T(T≤10) which indicates the number of test cases.

For each test case, the first line contains two integers n,m indicate the number of villages and the number of roads to be re-built. Next m lines, each line have three number i,j,wi, the length of a road connecting the village i and the village j is wi.

Output

output the minimum cost and minimum Expectations with two decimal places. They separated by a space.

Sample Input

1
4 6
1 2 1
2 3 2
3 4 3
4 1 4
1 3 5
2 4 6

Sample Output

6 3.33

Hint

题意

给你一个无向图,保证边权都不相同,让你求一棵最小生成树。

然后说有一个人在这棵树上瞎选起点和终点,问这个人走路的期望是多少。

题解:

典型的两道傻逼题杂糅在一起的题……

最小生成树跑kruskal

期望的话,考虑边(u,v,c),那么对答案贡献就是size[u] * (n-size[u]) * c * n(n-1)/2

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1000005;
int n,m;
int fa[maxn];
double ans2;
vector<pair<int,int> >E[maxn];
int fi(int u){
    return u != fa[u] ? fa[u] = fi( fa[u] ) : u;
}
void uni(int x,int y){
    int p=fa[x],q=fa[y];
    if(p==q)return;
    fa[p]=q;
}
struct node{
    int x,y,z;
}p[maxn];
bool cmp(node a,node b){
    return a.z<b.z;
}
void init(){
    ans2=0;
    for(int i=0;i<maxn;i++)fa[i]=i;
    memset(p,0,sizeof(p));
    for(int i=0;i<maxn;i++)E[i].clear();
}
int dfs(int x,int f){
    int sz = 0;
    for(int i=0;i<E[x].size();i++){
        int v = E[x][i].first;
        if(v==f)continue;
        int tmp = dfs(v,x);
        sz+=tmp;
        ans2 = ans2 + 1.0 * tmp * (n-tmp) * E[x][i].second;
    }
    return sz+1;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        init();
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&p[i].x,&p[i].y,&p[i].z);
        }
        sort(p+1,p+1+m,cmp);
        long long ans = 0;
        for(int i=1;i<=m;i++){
            int p1=fi(p[i].x),q1=fi(p[i].y);
            if(p1==q1)continue;
            uni(p1,q1);
            ans+=p[i].z;
            E[p[i].x].push_back(make_pair(p[i].y,p[i].z));
            E[p[i].y].push_back(make_pair(p[i].x,p[i].z));
        }
        dfs(1,0);
        ans2 = ans2 * 1.0 * 2.0 * 1.0  / (1.0* n)  / (n - 1.0);
        printf("%I64d %.2lf\n",ans,ans2);
    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5687067.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞