HDU 5745 La Vie en rose 暴力

La Vie en rose

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5745

Description

Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2…pm. So, he wants to generate as many as possible pattern strings from p using the following method:

  1. select some indices i1,i2,…,ik such that 1≤i1<i2<…<ik<|p| and |ij−ij+1|>1 for all 1≤j<k.
  2. swap pij and pij+1 for all 1≤j≤k.

Now, for a given a string s=s1s2…sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n≤105,1≤m≤min{5000,n}) — the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.

Output

For each test case, output a binary string of length n. The i-th character is “1” if and only if the substring sisi+1…si+m−1 is one of the generated patterns.

Sample Input

3
4 1
abac
a
4 2
aaaa
aa
9 3
abcbacacb
abc

Sample Output

1010
1110
100100100

Hint

题意

给你一个串s,然后给你个串s2

s2可以在其中选择出一个子序列,子序列中相邻的元素距离至少差2,然后交换前后位置(建议读题,我说的不是很清楚……)

再去匹配,问你有哪些位置可以匹配。

题解:

正解是dp+bitset优化

现场做的时候,看大多数队伍都过了,就感觉应该是傻逼暴力题了,剪剪枝就过了。。。

建议还是去写正解,正解其实也很好写的……

代码

#include<bits/stdc++.h>
using namespace std;

int n,m;
char s1[100004],s2[5005],s3[5005];
int sum[100004][26];
int tmp[26];
void solve(){
    string ans="";
    memset(sum,0,sizeof(sum));
    memset(tmp,0,sizeof(tmp));
    memset(s3,0,sizeof(s3));
    scanf("%d%d",&n,&m);
    scanf("%s%s",s1+1,s2+1);
    s2[m+1]='.';
    for(int i=1;i<=n;i++){
        for(int j=0;j<26;j++){
            sum[i][j]=sum[i-1][j];
        }
        sum[i][s1[i]-'a']++;
    }
    for(int i=1;i<=m;i++)
        tmp[s2[i]-'a']++;

    for(int i=1;i<=m+1;i++)
        s3[i]=s2[i];

    for(int i=1;i<=n;i++){
        int flag = 1;
        if(i+m-1>n){
            ans+='0';
            continue;
        }
        for(int j=0;j<26;j++){
            if(sum[i+m-1][j]-sum[i-1][j]!=tmp[j]){
                flag = 0;
                break;
            }
        }
        if(flag==0){
            ans+='0';
            continue;
        }
        int ff = 0;
        int len = 0;
        for(int j=1;j<=m;j++){
            len = max(len,j);
            if(s2[j]==s1[i+j-1]){
                ff=0;
            }else if(ff==0&&s2[j+1]==s1[i+j-1]){
                swap(s2[j+1],s2[j]);
                ff=1;
            }else{
                flag=0;
                break;
            }
        }
        for(int j=1;j<=len+1;j++)
            s2[j]=s3[j];
        if(flag==0){
            ans+='0';
            continue;
        }
        ans+='1';
    }
    cout<<ans<<endl;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--)solve();
    return 0;
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5692872.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞