HDU 5832 A water problem 水题

A water problem

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5832

Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input

10001
0
333

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

Hint

题意

给你一个数,问你这个数是否能够整除137和73

题解:

这两个数互质,其实就是问你能否整除10001

这个直接扫一遍就好了。

用string可能会TLE,所以老老实实用char就好了

代码

#include<bits/stdc++.h>
using namespace std;

char s[10000005];
int cas = 0;
int main(){
    while(scanf("%s",s)!=EOF){
        int mod1 = 0;int len=strlen(s);
        for(int i=0;i<len;i++){
            mod1=(mod1*10+s[i]-'0')%10001;
        }
        if(mod1==0)printf("Case #%d: YES\n",++cas);
        else printf("Case #%d: NO\n",++cas);
    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5771009.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞