HDU 5842 Lweb and String 水题

Lweb and String

题目连接:

http://acm.hdu.edu.cn/showproblem.php?pid=5842

Description

Lweb has a string S.

Oneday, he decided to transform this string to a new sequence.

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing).

You need transform every letter in this string to a new number.

A is the set of letters of S, B is the set of natural numbers.

Every injection f:A→B can be treat as an legal transformation.

For example, a String “aabc”, A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3.

Now help Lweb, find the longest LIS which you can obtain from S.

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)

Input

The first line of the input contains the only integer T,(1≤T≤20).

Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105.

Output

For each test case, output a single line “Case #x: y”, where x is the case number, starting from 1. And y is the answer.

Sample Input

2
aabcc
acdeaa

Sample Output

Case #1: 3
Case #2: 4

Hint

题意

给你一个字符串,你可以把字符变成数字,然后让你构造一下,使得LIS最长是多少

题解:

其实就是字母个数,这个很显然嘛。

代码

#include<bits/stdc++.h>
using namespace std;

int cas;
string s;
int cnt[26];
int main(){
    int t;scanf("%d",&t);
    while(t--){
        cin>>s;
        int ans = 0;
        memset(cnt,0,sizeof(cnt));
        for(int i=0;i<s.size();i++){
            cnt[s[i]-'a']++;
            if(cnt[s[i]-'a']==1)ans++;
        }
        printf("Case #%d: %d\n",++cas,ans);
    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5771027.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞