bzoj 1789: [Ahoi2008]Necklace Y型项链 贪心

1789: [Ahoi2008]Necklace Y型项链

Time Limit: 20 Sec  Memory Limit: 256 MB

题目连接

http://www.lydsy.com/JudgeOnline/problem.php?id=1789

Description

欢乐岛上众多新奇的游乐项目让小可可他们玩的非常开心。现在他们正在玩比赛串项链的游戏,谁串的最快就能得到优厚的奖品。这可不是普通的项链,而是一种Y 型项链,项链的最中间有一颗大珍珠作为结合点,从大珍珠上连出来3条由各种宝石串起来的链子。比赛的规则是这样的:每次可以从三条链子中某一条的一端取下 来一个宝石,或者安上去一个宝石,称为一次操作,经过若干次操作,最终使得三条链子完全相同。想要赢得比赛,那么只能使用尽量少的操作次数。假设每种宝石 都有无数多个以供使用,且链子足够长。你能帮助小可可赢得比赛吗? 注:由于对Y型项链的宝石数没有特殊的要求,所以即使你把所有宝石都取下来,也是一个可以接受的方案(三根没有串宝石的绳子也是完全一样的).

Input

一共有3行,表示Y型项链的三条链子,每行开始有一个数字N,表示初始时这条链子上串有N个宝石(N<=50),随后是一个空格,然后是N个’A’ 和’Z’之间的字符,表示这个链子上的宝石,每个字母表示一种不同的宝石,这个字符串最左边的字符表示的是离大珍珠最近的那个宝石,而最右边的表示的是在 链子末端的宝石。

 

Output

只有一个整数,表示所需要的最少的操作次数.

 

Sample Input

3 CAT
3 TAC
5 CATCH

Sample Output

8

HINT

 提示:100%的数据中,N<=50.
50%的数据中,N<=20.

题意

 

题解:

对于任意两个串,都求一次从头开始的最长公共字串,然后贪心删除就好了

代码:

 

//qscqesze
#include <cstdio>
#include <cmath>
#include <cstring>
#include <ctime>
#include <iostream>
#include <algorithm>
#include <set>
#include <vector>
#include <sstream>
#include <queue>
#include <typeinfo>
#include <fstream>
#include <map>
#include <stack>
typedef long long ll;
using namespace std;
//freopen("D.in","r",stdin);
//freopen("D.out","w",stdout);
#define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
#define test freopen("test.txt","r",stdin)  
#define maxn 2000001
#define mod 10007
#define eps 1e-9
int Num;
char CH[20];
//const int inf=0x7fffffff;   //нчоч╢С
const int inf=0x3f3f3f3f;
inline ll read()
{
    ll x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
inline void P(int x)
{
    Num=0;if(!x){putchar('0');puts("");return;}
    while(x>0)CH[++Num]=x%10,x/=10;
    while(Num)putchar(CH[Num--]+48);
    puts("");
}
//**************************************************************************************
int len[10];  
char str[10][100];  
int main()  
{  
    for(int i=1;i<=3;i++)  
    {  
        scanf("%d%s",&len[i],str[i]+1);  
    }  
    int ans=len[1]+len[2]+len[3];  
    int co,res,tmp;  
    for(int i=1;i<=3;i++)  
    {  
        for(int j=i+1;j<=3;j++)  
        {  
            tmp=co=0;  
            for(;co<min(len[i],len[j])&&str[i][co+1]==str[j][co+1];co++);  
            int k=6-i-j;  
            res=len[i]-co+len[j]-co;  
   
            for(;tmp<min(len[k],co)&&str[i][tmp+1]==str[k][tmp+1];tmp++);  
   
            if(co>=tmp) res+=(co-tmp)+len[k]-tmp;  
               
            ans=min(ans,res);  
   
        }  
    }  
    printf("%d\n",ans);  
    return 0;  
}  

 

    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/4536460.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞