BZOJ 2761: [JLOI2011]不重复数字 水题

2761: [JLOI2011]不重复数字

题目连接:

http://www.lydsy.com/JudgeOnline/problem.php?id=2761

Description

给出N个数,要求把其中重复的去掉,只保留第一次出现的数。
例如,给出的数为1 2 18 3 3 19 2 3 6 5 4,其中2和3有重复,去除后的结果为1 2 18 3 19 6 5 4。

Input

输入第一行为正整数T,表示有T组数据。
接下来每组数据包括两行,第一行为正整数N,表示有N个数。第二行为要去重的N个正整数。

Output

对于每组数据,输出一行,为去重后剩下的数字,数字之间用一个空格隔开。

Sample Input

2

11

1 2 18 3 3 19 2 3 6 5 4

6

1 2 3 4 5 6

Sample Output

1 2 18 3 19 6 5 4

1 2 3 4 5 6

Hint

题意

题解

用一个set去判重就好了嘛

水题

代码

#include<bits/stdc++.h>
using namespace std;
set<int> S;

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        S.clear();
        int n;scanf("%d",&n);
        for(int i=1;i<=n;i++){
            int x;scanf("%d",&x);
            if(!S.count(x)){
                if(i==1)printf("%d",x);
                else printf(" %d",x);
                S.insert(x);
            }
        }
        printf("\n");
    }
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5653833.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞