BZOJ 4706: B君的多边形 找规律

4706: B君的多边形

题目连接:

http://www.lydsy.com/JudgeOnline/problem.php?id=4706

Description

有一个正n多边形,我们要连接一些对角线,把这个多边形分成若干个区域。要求连接的对角线不能相交,每个点
可以连出也可以不连出对角线。(即最终不要求所有区域均为三角形)问总方案数mod (10^9+7)的结果。

Input

一行一个整数n,n≤10^6

Output

一行一个整数表示答案。

Sample Input

5

Sample Output

11

Hint

题意

题解:

打表找规律,然后oeis发现,这个东西叫做

    Schroeder's second problem (generalized parentheses); also called super-Catalan numbers or little Schroeder numbers. 

代码

#include<bits/stdc++.h>
using namespace std;
const int mod = 1e9+7;
const int maxn = 1e6+7;
long long inv[maxn];
long long f[maxn];
//(n+1) * a(n) = (6*n-3) * a(n-1) - (n-2) * a(n-2)
int main()
{
    inv[0]=1,inv[1]=1;
    f[0]=1,f[1]=1;
    int x;scanf("%d",&x);
    for(int i=2;i<=x;i++)
        inv[i]=(mod-mod/i)*inv[mod%i]%mod;
    for(int i=2;i<x;i++)
        f[i]=((6*i-3)*f[i-1]%mod-(i-2)*f[i-2]%mod+mod)%mod*inv[i+1]%mod;
    cout<<f[x-2]<<endl;
}
    原文作者:qscqesze
    原文地址: https://www.cnblogs.com/qscqesze/p/5928836.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞