1003 我要通过

“答案正确”是自动判题系统给出的最令人欢喜的回复。本题属于 PAT 的“答案正确”大派送 —— 只要读入的字符串满足下列条件,系统就输出“答案正确”,否则输出“答案错误”。

得到“答案正确”的条件是:

字符串中必须仅有P、 A、 T这三种字符,不可以包含其它字符;
任意形如xPATx 的字符串都可以获得“答案正确”,其中x或者是空字符串,或者是仅由字母 A组成的字符串;
如果aPbTc 是正确的,那么 aPbATca 也是正确的,其中 a、 b、 c均或者是空字符串,或者是仅由字母A组成的字符串。
现在就请你为 PAT 写一个自动裁判程序,判定哪些字符串是可以获得“答案正确”的。

输入格式:

每个测试输入包含 1 个测试用例。第 1 行给出一个正整数n (<10),是需要检测的字符串个数。接下来每个字符串占一行,字符串长度不超过 100,且不包含空格。

输出格式:

每个字符串的检测结果占一行,如果该字符串可以获得“答案正确”,则输出 YES,否则输出NO

输入样例

8
PAT
PAAT
AAPATAA
AAPAATAAAA
xPATx
PT
Whatever
APAAATAA

输出样例

YES
YES
YES
YES
NO
NO
NO
NO

源代码

#include <stdio.h>

#include <string.h>

#define TRUE 1
#define FALSE 0

// 判断字符串是否全部由指定字符组成,从索引index处比较length个字符
int checkStr(char *str, int index, int length, char ch)
{
    for (int i = index; i < length; i++)
    {
        if (str[i] != ch)
        {
            // printf("%c", str[i]);

            // printf("%c", ch);
            return FALSE;
        }
    }
    return TRUE;
}

// 用于判断字符串是否符合要求
int passStr(char *str, int length)
{
    // 是够全部由PAT三个字符组成
    for (int i = 0; i < length; i++)
    {
        if (!((str[i] == 'P') || (str[i] == 'A') || (str[i] == 'T')))
        {
            return FALSE;
        }
    }

    //P左侧字符串长度
    int length_P_left = strchr(str, 'P') - &str[0];
    // P和T之间的字符串长度
    int length_PT_mid = strchr(str, 'T') - strchr(str, 'P') - 1;
    //T右侧的字符串长度
    int length_T_right = &str[strlen(str) - 1] - strchr(str, 'T');

    //printf("%d %d %d\n", length_P_left, length_PT_mid, length_T_right);

    // PT之间不能为空字符串
    if (length_PT_mid == 0)
    {
        return FALSE;
    }

    //检查P和T左侧,之间和右侧的字符串是否全部由A组成
    if (!(checkStr(str, 0, length_P_left, 'A') && checkStr(str, length_P_left + 1, length_PT_mid, 'A') &&
          checkStr(str, length_P_left + length_PT_mid + 2, length_T_right, 'A')))
    {
        //printf("PT左右的字符串不全为A");
        return FALSE;
    }

    //如果全部由A组成再比较三个部分的A的数量是否满足下列关系
    // 左侧A的数量 * 中间A的数量 = 右侧A的数量
    if (!(length_P_left * length_PT_mid == length_T_right))
    {
        //printf("长度不符合规定");
        return FALSE;
    }
    return TRUE;
}

int main()
{

    // 字符串的数量
    int count;

    // 保存结果的数组
    char result[100][4];

    // 每个字符串长度不超过100
    char str[100];

    scanf("%d", &count);

    //需要检测的字符串数量是小于10的正整数
    if (count > 0 && count < 10)
    {
        for (int i = 0; i < count; i++)
        {
            scanf("%s", str);

            // 符合条件则在数组中保存YES
            if (passStr(str, strlen(str)) == TRUE)
            {
                strcpy(result[i], "YES");
            }

            // 否则保存NO
            else
            {
                strcpy(result[i], "NO");
            }
        }
    }

    for (int i = 0; i < count; i++)
    {
        printf("%s\n", result[i]);
    }

    return 0;
}
    原文作者:画家的野猫
    原文地址: https://www.jianshu.com/p/b47054cae840
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞