PAT 1110 Complete Binary Tree[判断完全二叉树]

1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (20) which is the total number of nodes in the tree — and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NOand the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

题目大意:给出一棵树二叉树,判断是否是完全二叉树,如果是那么输出最后一个节点;如果不是输出根节点。 

 //第一次见完全二叉树的题目,想起了完全二叉树的性质,存储树的话,就用结构体数组,下标表示当前节点号;首先求出树的高度根据logn,看是否余数为0,判断是否+1;那么前n-1层的节点要是满的,并且再通过只有一个左子节点或者右子节点的树只有一个,那么来判断是否是完全二叉树;并且结构体里有一个属性是father默认为-1。感觉好复杂,就没有用代码实现。

代码来自:https://www.liuchuo.net/archives/2158

#include <iostream>
#include <queue>
#include <vector>
#include <string>
using namespace std;
struct TREE {
    int left, right;
};
int main() {
    int n, root = 0;
    scanf("%d", &n);
    vector<TREE> tree(n);
    vector<int> book(n);
    for(int i = 0; i < n; i++) {
        string l, r;
        cin >> l >> r;//使用字符串读取,也必须使用字符串,
        if(l == "-") {
            tree[i].left = -1;//如果左右为空的话,则标记为-1.
        } else {
            tree[i].left = stoi(l);//不用使用-'0'将其转换,直接使用stoi函数即可
            book[tree[i].left] = 1;
        }
        if(r == "-"){
            tree[i].right = -1;
        } else {
            tree[i].right = stoi(r);
            book[tree[i].right] = 1;
        }
    }
    for(int i = 0; i < n; i++) {
        if(book[i] == 0) {
            root = i;
            break;//没有出现的便是根!
        }
    }
    queue<int> q;
    q.push(root);
    int cnt = 0, lastnode = 0;
    while(!q.empty()) {
        int node = q.front();
        q.pop();
        if(node != -1) {
            lastnode = node;
            cnt++;//记录层次遍历在-1出现之前的节点数
        }else {
            if(cnt != n)
                printf("NO %d", root);
            else
                printf("YES %d", lastnode);
            return 0;
        }
        q.push(tree[node].left);//如果左右子节点为空,那么就将-1push进去了
        q.push(tree[node].right);
    }
    return 0;
}

 

//学习了!

1.根据输入建树,每个节点因为本身就是ID,左右如果是空节点,那么就赋值为-1.

2.根节点是怎么找到的呢?在建树输入的过程中,如果一个点没有出现,那么就是根节点,因为都在一棵树中!都是表示的是子节点,如果没出现,就表示它不是子节点,而是根节点!

3.如何去判断是否是CBT呢?使用层次遍历!并且记录当前层次遍历的个数,根据CBT的性质,如果当前出现空节点,但是遍历过的点数!=总结点数,那么就不是二叉树,可以画一个图试试!使用队列!

//学习了!

    原文作者:lypbendlf
    原文地址: https://www.cnblogs.com/BlueBlueSea/p/9571976.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞