问题描述
X星球的流行宠物是青蛙,一般有两种颜色:白色和黑色。
X星球的居民喜欢把它们放在一排茶杯里,这样可以观察它们跳来跳去。
如下图,有一排杯子,左边的一个是空着的,右边的杯子,每个里边有一只青蛙。
*WWWBBB
其中,W字母表示白色青蛙,B表示黑色青蛙,*表示空杯子。
X星的青蛙很有些癖好,它们只做3个动作之一:
1. 跳到相邻的空杯子里。
2. 隔着1只其它的青蛙(随便什么颜色)跳到空杯子里。
3. 隔着2只其它的青蛙(随便什么颜色)跳到空杯子里。
对于上图的局面,只要1步,就可跳成下图局面:
WWW*BBB
本题的任务就是已知初始局面,询问至少需要几步,才能跳成另一个目标局面。
输入为2行,2个串,表示初始局面和目标局面。
输出要求为一个整数,表示至少需要多少步的青蛙跳。
样例输入
*WWBB
WWBB*
样例输出
2
样例输入
WWW*BBB
BBB*WWW
样例输出
10
数据规模和约定
我们约定,输入的串的长度不超过15
资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
水题,直接搜索并用map记录状态
#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
#define pb push_back
#define rep(i,a,b) for(int i=a;i<b;i++)
#define rep1(i,b,a) for(int i=b;i>=a;i--)
using namespace std;
const int N=1e5+100;
ll arr[4][4];
int main()
{
string str1;
string str2;
cin>>str1>>str2;
queue<string>q;
map<string,int>mp;
mp[str1]=0;
q.push(str1);
while(!q.empty())
{
string str=q.front();
q.pop();
int cnt=mp[str];
//cout<<str<<' '<<mp[str]<<endl;
if(str==str2)
{
cout<<mp[str]<<endl;
return 0;
}
int len=str.size();
rep(i,0,len)
{
if(str[i]=='*')
{
rep(j,1,4)
{
if(i-j>=0&&str[i-j]!='*')
{
string str3=str;
swap(str3[i],str3[i-j]);
if(!mp.count(str3))
mp[str3]=cnt+1,q.push(str3);
}
}
rep(j,1,4)
{
//cout<<str[i+j]<<endl;
if(i+j<len&&str[i+j]!='*')
{
string str3=str;
swap(str3[i],str3[i+j]);
if(!mp.count(str3))
mp[str3]=cnt+1,q.push(str3);
}
}
}
}
}
return 0;
}