Description
给出一个二进制的非负整数x,x<232,把它转换成十进制数输出。
Input
输入为多行,每行一个二进制非负整数x。
Output
每行输出x对应的十进制数值。
Sample Input
0
1
01
10
11
10000
1
1111111111111111
Sample Output
0
1
1
2
3
33
65535
HINT
注意数据范围!!!
思路:
用一个字符串数组将二进制的各位储存下来。然后倒叙进行运算。
注:输入的为字符串。1为字符1,不是数字1。要想的到实际的值,需要-48。
注:pow函数为double型 运算时会有误差存在。一般整型运算时(int)pow。但这里数据过大可能溢出。需要long long int。
代码:
#include<math.h>
#include<stdio.h>
#include<string.h>
int main()
{
char a[33];
long long int i,n,sum;
while(scanf("%s",a)!=EOF)
{
sum=0;
n=strlen(a);
for(i=n-1;i>=0;i--)
sum+=(a[i]-'0')*((long long int)pow(2,n-1-i));
printf("%lld\n",sum);
}
}