HDU 1005 :: Number Sequence

/*Problem Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n – 1) + B * f(n – 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single
line(1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case
is not to be processed.

Output
For each test case, print the value of f(n) on a single line.
Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2

5

分析:
由题意可知,f(n)由前两个元素得出,并且大于等于0小于等于6,故由两个元素推到f(n)的情况有49种,用数组记录下来这种
情况,便可确定周期,从而取余,快速得出答案   */

#include<iostream>
#include<stdio.h>
using namespace std;
int f[100000005];
int main()
{
 int a,b,n;
 f[1]=f[2]=1;
 while(scanf(“%d%d%d”,&a,&b,&n) && a+b+n)
 {
  for(int i=3;i<=n;i++)
        {
   f[i]=(a*f[i-1]+b*f[i-2])%7;
   //如果在找到f(n)的值之前就已经找到循环周期
   for(int j=2;j<i;j++)
   { if(f[j]==f[i]&&f[j-1]==f[i-1])
    {
     int s=i-j;
     cout<<f[(n-j)%s+j]<<endl;
     goto Next;
    }
   }
  }
  cout<<f[n]<<endl;
  Next: ;
 }
 return 0;
}

点赞