HDU2602 01揹包问题

挺想哭的调试了好久都没用,结果是int的问题。。。

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

#include<iostream>
#include<stdio.h>
#include<memory.h>
using namespace std;
int mon[1003],w[1003];
int f[1001]={0};
int max(int x,int y)
{
        if(x>y)
                return x;
        else
                return y;
}
int main()
{
        int n,v,i,j,k;
        int t;
        cin>>t;
        for( k=0;k<t;k++)
        {
                memset(f,0,sizeof(f));
                cin>>n>>v;
                for(i=0;i<n;i++)
                {
                        cin>>mon[i];
                }
                 for(i=0;i<n;i++)
                {
                        cin>>w[i];
                }
                //for(i=0;i<n;i++)
                // {
                // cout<<mon[i]<<w[i];
                // }
                for(i=0;i<n;i++)
                {
                        for(j=v;j>=w[i];j--)
                        {
                              f[j]=max(f[j],f[j-w[i]]+mon[i]);
                              //cout<<f[v]<<endl;
                        }
                }
                cout<<f[v]<<endl;
        }
        /*for(i=0;i<t;i++) { cout<<a[i]<<endl; }*/
        return 0;
}
点赞