Spell checker
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 15078 | Accepted: 5487 |
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#’ on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#’ on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: ” is correct”. If the word is not correct then write this word first, then write the character ‘:’ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i is has have be my more contest me too if award # me aware m contest hav oo or i fi mre #
Sample Output
me is correct aware: award m: i my me contest is correct hav: has have oo: too or: i is correct fi: i mre: more me
分析:本题题意是一个字符串s1可不可以通过(1)随意为之增加一个随意字符(2)删除随意一个字符(3)改变一个字符等到另一个字符说s2.通过题意我们可知我们必须先判断这个字符是否和字典中的字符匹配如果匹配结束,如果不匹配我们看是否通过以上三个步骤获得一个和字典中匹配的字符串。
由于三个操作只能操作一次,为了提高效率我们需要剪枝,也就是当s1的长度和s2的长度只差的绝对值大于1时我们就判断s1一定不能变到s2.代码如下(G++提交超时,C++提交比较快,是由于头文件的问题,g++预编译不是太好)
#include <iostream>
#include <string>
#include <vector>
#include <map>
#include <cmath>
using namespace std;
bool chack(string s1, string s2)
{
int len1 = s1.length();
int len2 = s2.length();
int i=0, j=0;
if (abs(len2-len1)>1)
{
return false;
}
if (len1 == len2)
{
while (i < len1 && s1[i] == s2[i])
{
i++;
}
while (++i < len1)
{
if (s1[i]!=s2[i])
{
return false;
}
}
}
if (len1 == len2+1)
{
while(i<len2 && s1[i]==s2[i])
i++;
while (i < len2 )
{
if (s1[i+1] != s2[i])
{
return false;
}
i++;
}
}
if (len1 == len2-1)
{
while(i<len1 && s1[i]==s2[i])
i++;
while (i < len1 )
{
if (s1[i] != s2[i+1])
{
return false;
}
i++;
}
}
return true;
}
int main()
{
vector<string> dicvec;
map<string, int> dicmap;
vector<string>::iterator ptor;
string s1, s2, s3;
int icount = 0;
while (cin >> s1 && s1!="#")
{
dicvec.push_back(s1);
dicmap[s1] = icount;
}
while (cin >> s2 && s2 != "#")
{
if (dicmap.find(s2)!=dicmap.end())
{
cout<<s2<<" is correct"<<endl;
continue;
}
cout<<s2<<":";
for (ptor = dicvec.begin(); ptor!=dicvec.end(); ptor++)
{
s3 = *ptor;
if(chack(s3, s2)==true)
{
cout<<" "<< s3;
}
}
cout<<endl;
}
return 0;
}