A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 206363 Accepted Submission(s): 39670
Problem Description I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110 answer:
#include"stdio.h"
#include"string.h"
int main()
{
int n,d,m;
char a[1001],b[1001];
int len1,len2,k;
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
int str1[1001]={0},str2[1001]={0},s[1001]={0};
d=0;
scanf("%s %s",a,b);
len1=strlen(a);
len2=strlen(b);
if(len1>len2)
{
k=len1;
}
else
{
k=len2;
}
for(j=0;j<len1;j++)
str1[j]=a[len1-1-j]-'0';
for(j=0;j<len2;j++)
str2[j]=b[len2-1-j]-'0';
for(j=0;j<k;j++)
{
s[j]=(str1[j]+str2[j]+d)%10;
d=(str1[j]+str2[j]+d)/10;
}
printf("Case %d:\n",i);
printf("%s + %s = ",a,b);
if(d!=0)
printf("%d",d);
for(j=k-1;j>=0;j--)
{
printf("%d",s[j]);
}
printf("\n");
m=n-i;
if(m>=1)
printf("\n");
}
return 0;
}