HDU1231: 最大連續子序列
目錄
用 [TOC]
來生成目錄:
問題描述
給定K個整數的序列{ N1, N2, …, NK },其任意連續子序列可表示爲{ Ni, Ni+1, …,
Nj },其中 1 <= i <= j <= K。最大連續子序列是所有連續子序列中元素和最大的一個,
例如給定序列{ -2, 11, -4, 13, -5, -2 },其最大連續子序列爲{ 11, -4, 13 },最大和
爲20。
在今年的數據結構考卷中,要求編寫程序得到最大和,現在增加一個要求,即還需要輸出該
子序列的第一個和最後一個元素。
Input
測試輸入包含若干測試用例,每個測試用例佔2行,第1行給出正整數K( < 10000 ),第2行給出K個整數,中間用空格分隔。當K爲0時,輸入結束,該用例不被處理。
Output
對每個測試用例,在1行裏輸出最大和、最大連續子序列的第一個和最後一個元
素,中間用空格分隔。如果最大連續子序列不唯一,則輸出序號i和j最小的那個(如輸入樣例的第2、3組)。若所有K個元素都是負數,則定義其最大和爲0,輸出整個序列的首尾元素。
Sample Input
6
-2 11 -4 13 -5 -2
10
-10 1 2 3 4 -5 -23 3 7 -21
6
5 -8 3 2 5 0
1
10
3
-1 -5 -2
3
-1 0 -2
0
Sample Output
20 11 13
10 1 4
10 3 5
10 10 10
0 -1 -2
0 0 01
先貼個完整、能pass的代碼
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
int main()
{
int K,i,in;
// while (~scanf("%d",&K),K)
while (cin>>K && K)
{
vector<int> vi;
for(i=0;i<K;++i)
{
scanf("%d",&in);
vi.push_back(in);
}
int currSum=0,maxSum=vi[0];//!!not 0
int begIdx=0,tempBegin=0,endIdx=K-1;
for(i=0;i<K;++i)
{
if (currSum<0)
{
tempBegin = i;//candidate
currSum=0;
}
currSum += vi[i]; //first
if (currSum>maxSum) //second
{
maxSum=currSum;
endIdx = i;
begIdx = tempBegin;//throw before
}
}
if (maxSum<0)//!!
{
printf("0 %d %d\n",vi[0],vi[K-1]);
continue;
}
cout<<maxSum<<' '<<vi[begIdx]<<' '<<vi[endIdx]<<endl;
}
return 1;
}
其中核心部分,也就是for()裏面的代碼還可以醬紫寫:
currSum += vi[i]; //first
if (currSum>maxSum) //second
{
maxSum=currSum;
endIdx = i;
begIdx = tempBegin;//throw before
}
if (currSum<0)
{
tempBegin = i+1;//candidate
currSum=0;
}
注意if (currSum<0){}塊的位置和tempBegin的取值。