L2-005. 集合相似度
时间限制 400 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序
Standard 作者 陈越
给定两个整数集合,它们的相似度定义为:Nc/Nt*100%。其中Nc是两个集合都有的不相等整数的个数,Nt是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。
输入格式:
输入第一行给出一个正整数N(<=50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(<=104),是集合中元素的个数;然后跟M个[0, 109]区间内的整数。
之后一行给出一个正整数K(<=2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。
输出格式:
对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。
输入样例:
3 3 99 87 101 4 87 101 5 87 7 99 101 18 5 135 18 99 2 1 2 1 3
输出样例:
50.00% 33.33%
先排序,再去重,用vector就好了,用set容易TLE。
#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;
void fun(vector<int> v1, vector<int> v2)
{
vector<int> v;
int res = v1.size() + v2.size();
v.resize(res);
copy(v1.begin(), v1.end(), v.begin());
copy(v2.begin(), v2.end(), v.begin() + v1.size());
sort(v.begin(), v.end());
vector<int>::iterator it = unique(v.begin(), v.end());
v.erase(it, v.end());
int res2 = v.size();
printf("%.2lf%%\n", abs((res2 - res)) / (double)res2 * 100);
}
int main()
{
int n;
cin >> n;
vector<vector<int> > v;
for (int i = 0; i < n; i++)
{
int m;
cin >> m;
vector<int> vv(m);
for (int j = 0; j < m; j++)
cin >> vv[j];
sort(vv.begin(), vv.end());
vector<int> :: iterator it = unique(vv.begin(), vv.end());
vv.erase(it, vv.end());
v.push_back(vv);
}
cin >> n;
while (n--)
{
int p, q;
cin >> p >> q;
fun(v[p - 1], v[q - 1]);
}
return 0;
}