AGTC
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 7780 | Accepted: 3087 |
Description
Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:
- Deletion: a letter in x is missing in y at a corresponding position.
- Insertion: a letter in y is missing in x at a corresponding position.
- Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.
Illustration
A G T A A G T * A G G C | | | | | | | A G T * C * T G A C G CDeletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like
A G T A A G T A G G C | | | | | | | A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).
In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.
Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.
Write a program that would minimize the number of possible operations to transform any string x into a string y.
Input
The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.
Output
An integer representing the minimum number of possible operations to transform any string x into a string y.
Sample Input
10 AGTCTGACGC 11 AGTAAGTAGGC
Sample Output
4
#include <stdio.h>
char s1[1001], s2[1001];
int dp[1001];
int main()
{
int lenS1, lenS2, old, t;
while(1)
{
if(EOF==scanf("%d %s", &lenS1, s1))break;
scanf("%d %s", &lenS2, s2);
for(int i=0; i<=lenS2; i++)
dp[i]=i;
for(int i=0; i<lenS1; i++)
{
old = dp[0];
dp[0] = i+1;
for(int j=0; j<lenS2; j++)
{
t=dp[j+1];
if(s1[i]==s2[j])
{
//dp[j+1]=dp[j];
dp[j+1]=old;
}
else
{
if(dp[j+1]>dp[j])dp[j+1]=dp[j];
if(dp[j+1]>old)dp[j+1]=old;
++dp[j+1];
}
old=t;
}
}
printf("%d\n", dp[lenS2]);
}
return 0;
}