Oulipo(KMP之子串个数)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15695    Accepted Submission(s): 6204

Problem Description The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

 

Output For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input

3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN  

Sample Output

1 3 0 题意:求出母串中包含多少个子串

#include <cstdio>
#include <cstring>
using namespace std;
char str[10001];
int ans;
char str1[1000005];
int next[10005];
void getnext(int len)
{
    int i = 0,k=-1;
    next[0] = -1;
    while(i<len)
    {
        if(k== -1 || str[i] == str[k])
        {
            i++;
            k++;
            next[i] = k;
        }
        else
            k = next[k];
    }
}
void KMP(char s[],char t[])
{
    int i=0,j=0;
    int len1=strlen(s);
    int len2=strlen(t);
    while(i<len2)
    {
        if(j==-1||s[j]==t[i])
        {
            ++i;
            ++j;
        }
        else
            j=next[j];
        if(j==len1)
        {
            ans++;
            j=next[j];//只要找到了就加一,并且不返回即可;
        }
    }
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        ans=0;
        memset(next,0,sizeof(next));
        scanf("%s",str);
        scanf("%s",str1);
        int len = strlen(str);
        getnext(len);
        KMP(str,str1);
        printf("%d\n",ans);
    }
    return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/kangyan__/article/details/77838741
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞