POJ2229Sumsets题解动态规划DP

Sumsets

Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 7686 Accepted: 3059

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1

2) 1+1+1+1+1+2

3) 1+1+1+2+2

4) 1+1+1+4

5) 1+2+2+2

6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

Source

USACO 2005 January Silver

参考NumberPyramids一题
不过此题有更好的递推做法。
状态:
d[i][j]表示前i个二的幂数凑成数j的方法数
空间可以降维到d[j]
状态转移方程:
d[j]=d[j]+d[j-c[i]]
c[i]=2^i
边界:
d[0]=1
代码:
#include<cstdio>

int d[1000005],c[25],n,i,j;
int main()
{
	scanf("%d",&n);
	c[0]=d[0]=1;
	for(i=1;i<=20;i++)
		c[i]=c[i-1]<<1;
	for(i=0;i<=20&&c[i]<=n;i++)
		for(j=c[i];j<=n;j++)
			d[j]=(d[j]+d[j-c[i]])%1000000000;
	printf("%d/n",d[n]);		
}
    原文作者:动态规划
    原文地址: https://blog.csdn.net/power721/article/details/5861487
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞