确定比赛名次
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12694 Accepted Submission(s): 5101
Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
Input 输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
Output 给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
Sample Input
4 3 1 2 2 3 4 3
Sample Output
1 2 4 3
Author 简单拓扑
/******************************
*
* acm: hdu-1285
*
* title: 确定比赛名次
*
* time : 2014.9.13
*
*******************************/
//考察拓扑排序
#include <stdio.h>
#include <stdlib.h>
#define MAXVEX 501
#define OK 1
#define ERROR 0
#define TRUE 1
#define FALSE 0
#define INFINITY 65535
typedef int Status; //表示状态
typedef struct EdgeNode
{
int adjvex;
// int weight; //非网图不需要
struct EdgeNode *next;
} EdgeNode;
typedef struct VertexNode //顶点表结点
{
int in; //顶点入度
int data; //顶点域, 存储顶点信息
EdgeNode *firstedge; //边表头指针
} VertexNode, AdjList[MAXVEX];
typedef struct graphAdjList
{
AdjList adjList;
int numVertexes, numEdges; //图中当前顶点数和边数
} graphAdjList, *GraphAdjList;
//创建邻接表
void CreateALGraph(GraphAdjList GL ,int numVertexes, int numEdges)
{
int i = 0;
int V_a, V_b;
EdgeNode *e;
GL->numVertexes = numVertexes;
GL->numEdges = numEdges;
for (i = 0; i <= GL->numVertexes; i++)
{
GL->adjList[i].in = 0;
GL->adjList[i].data = i;
GL->adjList[i].firstedge = NULL;
}
i = 0;
while (i < GL->numEdges)
{
scanf("%d%d", &V_a, &V_b);
e = (EdgeNode *)malloc(sizeof(EdgeNode));
e->adjvex = V_b;
e->next = GL->adjList[V_a].firstedge;
GL->adjList[V_a].firstedge = e;
GL->adjList[e->adjvex].in++;
i++;
}
}
//拓扑排序,假设GL无回路,输出拓扑排序
void TopologicalSort(GraphAdjList GL)
{
void Sort(int array[], int top);
EdgeNode *e;
int i, k, gettop;
int top = 0; //用于栈指针下标
int *stack; //建栈将入度为0的顶点入栈
stack = (int *)malloc(GL->numVertexes * sizeof(int ));
for (i = 1; i <= GL->numVertexes; i++)
{
if (0 == GL->adjList[i].in)
{
stack[++top] = i;
}
}
while (top != 0)
{
Sort(stack, top);
gettop = stack[top--];
for (e = GL->adjList[gettop].firstedge; e; e = e->next)
{
k = e->adjvex;
if (!(--GL->adjList[k].in))
{
stack[++top] = k;
}
}
if (top != 0)
{
printf("%d ", gettop);
}
else
{
printf("%d", gettop);
}
}
printf("\n");
}
void Sort(int array[], int top)
{
int i, j;
int k;
int temp;
for (i = 1; i < top; i++)
{
k = i;
for (j = i + 1; j <= top; j++)
{
if (array[j] > array[k])
{
k = j;
}
}
if (k != i)
{
temp = array[k];
array[k] = array[i];
array[i] = temp;
}
}
}
int main()
{
int N; //比赛队的总数
int M; //pk场次总数
graphAdjList GL;
while (~scanf("%d%d", &N, &M))
{
CreateALGraph(&GL, N, M);
TopologicalSort(&GL);
}
return 0;
}