HDU4324 Triangle LOVE【拓扑排序】

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 2683    Accepted Submission(s): 1084

Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!

Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.

  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

 

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.

For each case, the first line contains one integer N (0 < N <= 2000).

In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.

It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

 

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.

Take the sample output for more details.

 

Sample Input

2

5

00100

10000

01001

11101

11000

5

01111

00000

01000

01100

01110

 

Sample Output

Case #1: Yes

Case #2: No


题目大意:给你一个图,图中任意两点之间要么有正向边,要么有反向边。

判断是否含有a->b->c->a的三角形环。

思路:其实只要有环,就能构成三角形环。因为任意两点之间要么有正向边,

要么有反向边。如果现在有一个四元素环 a->b->c->d->a,若a不指向c,则

c必定指向a,所以必定存在三角形环。直接拓扑排序,如果不能排序,则有

三角环,输出“Yes”,能拓扑排序,则不含有三角环,输出”No”。


#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 2010;

int N,M,t;
int topo[MAXN],G[MAXN][MAXN],vis[MAXN];
char Map[MAXN][MAXN];

bool dfs(int u)
{
    vis[u] = -1;
    for(int v = 0; v < N; v++)
    {
        if(G[u][v])
        {
            if(vis[v] < 0)
                return false;
            else if(!vis[v] && !dfs(v))
                return false;
        }
    }
    vis[u] = 1;
    topo[--t] = u;
    return true;
}

bool toposort()
{
    t = N;
    memset(vis,0,sizeof(vis));
    for(int u = 0; u < N; u++)
    {
        if(!vis[u])
            if(!dfs(u))
                return false;
    }
    return true;
}

int main()
{
    int T,kase = 0;
    cin >> T;
    while(T--)
    {
        memset(G,0,sizeof(G));
        memset(topo,0,sizeof(topo));
        getchar();
        cin >> N;
        for(int i = 0; i < N; i++)
            cin >> Map[i];
        for(int i = 0; i < N; i++)
        {
            for(int j = 0; j < N; j++)
                if(Map[i][j] == '1')
                    G[i][j] = 1;

        }
        cout << "Case #" << ++kase << ": ";
        if(toposort())
            cout << "No" << endl;
        else
            cout << "Yes" << endl;
    }

    return 0;
}


    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/lianai911/article/details/42089111
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞