统计难题
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 52621 Accepted Submission(s): 18402
Problem Description Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input 输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.
注意:本题只有一组测试数据,处理到文件结束.
Output 对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana band bee absolute acm ba b band abc
Sample Output
2 3 1 0
Author Ignatius.L
Recommend
Ignatius.L | We have carefully selected several similar problems for you: 1075 1247 1671 1298 1800
题意求前缀
那么我们在每个节点 也就是每个字符 cnt++
这样统计前缀也就是求cnt
便可以求解了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX_N = 2000006;
int tree[MAX_N][30];
int cnt[MAX_N];
int tot;
void Insert(char *str){
int len = strlen(str);
int root = 0;
for(int i=0;i<len;++i){
int id = str[i]-'0';
if(!tree[root][id]) tree[root][id] = ++tot;
root = tree[root][id];
cnt[root]++;
}
}
int Find(char *str){
int len = strlen(str);
int root = 0;
for(int i =0;i<len;++i){
int id = str[i]-'0';
if(!tree[root][id]) return 0;
root = tree[root][id];
}
return cnt[root];
}
void init(){
for(int i= 0;i<=tot;++i){
cnt[i] = 0;
for(int j = 0;j<10;j++)
tree[i][j] = 26;
}
tot= 0;
}
int main(){
char s[25];
tot = 0;
while(cin.getline(s,12)){
int len = strlen(s);
if(len==0) break;
Insert(s);
}
while(scanf("%s",s)!=EOF){
printf("%d\n",Find(s));
}
return 0;
}