HDU4099-Revenge of Fibonacci(trie树+数学基础)

Revenge of Fibonacci

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 204800/204800 K (Java/Others)
Total Submission(s): 1944    Accepted Submission(s): 446

Problem Description The well-known Fibonacci sequence is defined as following:

  Here we regard n as the index of the Fibonacci number F(n).

  This sequence has been studied since the publication of Fibonacci’s book Liber Abaci. So far, many properties of this sequence have been introduced.

  You had been interested in this sequence, while after reading lots of papers about it. You think there’s no need to research in it anymore because of the lack of its unrevealed properties. Yesterday, you decided to study some other sequences like Lucas sequence instead.

  Fibonacci came into your dream last night. “Stupid human beings. Lots of important properties of Fibonacci sequence have not been studied by anyone, for example, from the Fibonacci number 347746739…”

  You woke up and couldn’t remember the whole number except the first few digits Fibonacci told you. You decided to write a program to find this number out in order to continue your research on Fibonacci sequence.  

Input   There are multiple test cases. The first line of input contains a single integer T denoting the number of test cases (T<=50000).

  For each test case, there is a single line containing one non-empty string made up of at most 40 digits. And there won’t be any unnecessary leading zeroes.  

Output   For each test case, output the smallest index of the smallest Fibonacci number whose decimal notation begins with the given digits. If no Fibonacci number with index smaller than 100000 satisfy that condition, output -1 instead – you think what Fibonacci wants to told you beyonds your ability.  

Sample Input

15 1 12 123 1234 12345 9 98 987 9876 98765 89 32 51075176167176176176 347746739 5610  

Sample Output

Case #1: 0 Case #2: 25 Case #3: 226 Case #4: 1628 Case #5: 49516 Case #6: 15 Case #7: 15 Case #8: 15 Case #9: 43764 Case #10: 49750 Case #11: 10 Case #12: 51 Case #13: -1 Case #14: 1233 Case #15: 22374  

Source
2011 Asia Shanghai Regional Contest  

题目大意: T组测试样例,问你一个数字串是哪个斐波那契数列的前缀,要求下标要最小

做法: 先算斐波那契数,因为数字较大,所以要用大数模板,考虑到询问的数字串最多为40个,所以在插入trie树时可以选择插入<=40个,这样可以节省很大的内存。 大数模板网上找的。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn = 7000000;
const int INF = 1e8;
int ch[maxn][10];
int val[maxn];
int cnt;
char c[200];
char str[200];
void add(char a[],char b[],char back[]){

    int i=strlen(a)-1,j=strlen(b)-1,k=0;
    int x,y,z;
    int up=0;
    while(i>=0||j>=0)
    {
        if(i<0)x=0;
        else x=a[i]-'0';
        if(j<0)y=0;
        else y=b[j]-'0';
        z=x+y+up;
        c[k++]=z%10+'0';
        up=z/10;
        i--;
        j--;
    }
    if(up>0)c[k++]=up+'0';
    for(i=0;i<k;i++)back[i]=c[k-1-i];
    back[k]='\0';
}
int getIdx(char  a){
    return a-'0';
}
void insert(char st[],int d){
    int u = 0;
    for(int i = 0; i < strlen(st) && i < 42; i++){
        int k = getIdx(st[i]);
        if(!ch[u][k]){
            val[cnt] = d;
            ch[u][k] = cnt++;
            memset(ch[cnt],0,sizeof ch[cnt]);
        }
        u = ch[u][k];
    }
}
int query(char st[]){
    int u = 0;
    for(int i = 0; i < strlen(st); i++){
        int k = getIdx(st[i]);
        if(!ch[u][k]){
            return -1;
        }
        u = ch[u][k];
    }
    return val[u];
}
void init(){
    cnt = 1;
    memset(ch[0],0,sizeof ch[0]);
    for(int i = 0; i < maxn; i++)
        val[i] = INF;
    char a[200],b[200],ans[200];
    a[0] = '1',a[1] = 0;
    b[0] = '1',b[1] = 0;
    insert(a,0);
    for(int i = 2; i < 100000; i++){
        if(strlen(b) > 70){
            a[strlen(a)-1] = 0;
            b[strlen(b)-1] = 0;
        }
        add(a,b,ans);
        insert(ans,i);
        strcpy(a,b);
        strcpy(b,ans);
    }
}
int main(){
    init();
    int ncase,T=1;
    cin >> ncase;
    while(ncase--){
        cin >> str;
        printf("Case #%d: %d\n",T++,query(str));
    }
    return 0;
}
    原文作者:Trie树
    原文地址: https://blog.csdn.net/mowayao/article/details/32718675
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞