NYOJ 221 Tree (二叉树遍历)

Tree

时间限制:
1000 ms  |  内存限制:
65535 KB 难度:
3

描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 

                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 

However, doing the reconstruction by hand, soon turned out to be tedious. 

So now she asks you to write a program that does the job for her! 

输入
The input will contain one or more test cases. 

Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 

Input is terminated by end of file.

输出
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB

题意:

给你了二叉树的先序遍历和中序遍历,让你写出这个二叉树的后序遍历。

分析:

先序遍历:先访问根节点,然后以前序访问左子树,右子树。
中序遍历:左子树,当前节点,右子树。
根据先序和中序遍历的特点,可以发现如下规律:
先序遍历的每个节点,都是当前子树的根节点。同时,以对应的节点为边界,就会把中序遍历的结果分为左子树和右子树。例如:
先序:a b d c e f 
‘a’是根节点
中序:d b a e c f
‘a’是根节点,把字符串分成左右两个子树
‘a’是先序遍历节点的第一个元素,可以看出,它把中序遍历的结果分成’db’和’ecf’两部分。这就是’a’的左子树和右子树的遍历结果。
如果能够找到先序遍历中对应的左子树和右子树,就可以把’a’作为当前的根节点,然后依次递归下去,这样就能够依次恢复左子树和右子树的遍历结果。 

后序遍历二叉树的操作定义为:
若二叉树为空,则空操作;否则
(1)后序遍历左子树;
(2)后序遍历右子树;
(3)访问根结点。

 
#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
typedef struct node
{
    char ch;
    struct node *left, *right;
}node;         //定义节点的结构

node *creat(char *pre, char *in, int len)    //创建后序遍历的函数
{
    int k;
    if (len <= 0)
        return NULL;
    node *head = (node*)malloc(sizeof(node));
    head -> ch = *pre;
    char *p;
    for (p = in; p != NULL; p++){
        if (*p == *pre)    //在中序遍历的序列中得到与先序相同的节点 
            break;
    }
    k = p - in;
    head -> left = creat(pre + 1, in, k);    //递归调用得到左子树 
    head -> right = creat(pre + k + 1, p + 1, len - k - 1);    //得到右子树
    return head;
}

void print(node *head)    //打印后序遍历序列
{
    if (head == NULL)
        return ;
    print(head -> left);
    print(head -> right);
    cout << head -> ch;
}

int main()
{
    char pre[30], in[30];      //存储先序和中序遍历的序列
    node *head;
    head = (node*)malloc(sizeof(node));
    while (cin >> pre >> in){
        int len = strlen(pre);
        head = creat(pre, in, len);
        print(head);
        cout << endl;
    }
    return 0;
}
        

    原文作者:a2459956664
    原文地址: https://blog.csdn.net/a2459956664/article/details/51818966
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞