国际象棋跳马问题

Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

《国际象棋跳马问题》
《国际象棋跳马问题》

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace std;
int n,m;
bool found;
int map[26][26];
int fangxiang[8][2]=
{
{ -2, -1 },
{ -2, 1 },
{ -1, -2 },
{ -1, 2 },
{ 1, -2 },
{ 1, 2 },
{ 2, -1 },
{ 2, 1 } };
struct node
{
    int x;
    int y;
}way[26*26];
void print()//输出 
{
    for (int i = 0; i < n * m; i++)
        printf("%c%d", way[i].x + 'A', way[i].y + 1);
    printf("\n\n");
}
bool ok(int x,int y)//判断 
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    if(map[x][y])
        return false;
    return true;
}
void dfs(int xx,int yy,int step)//深搜
{
    way[step].x=xx;
    way[step].y=yy;
    if(step==n*m-1)
    {
        found=true;
        return;
    }
    for(int i=0;i<8;i++)
    {
        if(ok(xx+fangxiang[i][0],yy+fangxiang[i][1]))
        {
            map[xx+fangxiang[i][0]][yy+fangxiang[i][1]]=true;
            dfs(xx+fangxiang[i][0],yy+fangxiang[i][1],step+1);
            if(found)
                return;
            map[xx+fangxiang[i][0]][yy+fangxiang[i][1]]=false;
        }
    }
    
} 
int main()
{
    int t;
    cin>>t;
    int s = 0;
    while (t--)
    {
        s++;
        printf("Scenario #%d:\n", s);
        cin>>m>>n;
        memset(map, 0, sizeof(map));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                found=false;
                map[i][j]=true;
                dfs(i,j,0);
                if(found)
                    break;
                map[i][j]=false;
            }
            if(found)
                break;
        }
        if (found)
            print();
        else
            printf("impossible\n\n");
    } 
    //system("pause");
    return 0;
}

View Code

 

    原文作者:骑士周游问题
    原文地址: https://blog.csdn.net/baoluqi/article/details/47972701
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞