HDU 3792 Twin Prime Conjecture

If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that “There are infinite consecutive primes differing by 2”. 
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.

Input

Your program must read test cases from standard input. 
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.

Output

For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.

Sample Input

1
5
20
-2

Sample Output

0
1
4

题意:给定一个数,在比这个数小的素数里面,问存在多少对连续两个素数差值为2

思路:第一步打素数表(1e6个),第二步对每一个数字处理,查找这个数前面有多少对,并且把前面的数赋值存在num里面即可,注释里有详细步骤

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int prime[100005];
int num[1000005];
int vis[1000005];
void Prime()//欧拉筛选法
{
    int cnt=0;
    memset(vis,0,sizeof(vis));
    for(int i=2; i<1000005; i++)
    {
        if(!vis[i])
            prime[cnt++]=i;
        for(int j=0; j<cnt&&i*prime[j]<1000005; j++)
        {
            vis[i*prime[j]]=1;
            if(i%prime[j]==0)//关键
                break;
        }
    }

}
int main()
{
    Prime();//打表
    int n;
    memset(num,-1,sizeof num);
    int cnt=0;
    for(int i=1; i<100000; i++)//处理每一个数字
    {
        if(prime[i]-prime[i-1]==2)
        {
            for(int j=prime[i]-1; j>=0; j--)//更新这个数之前的数
            {
                if(num[j]!=-1) break;
                num[j]=cnt;
            }
            num[prime[i]]=++cnt;//更新这个数
        }
    }

    while(scanf("%d",&n)==1)
    {
        if(n<0) break;
        if(n==0) printf("0\n");
        else
            printf("%d\n",num[n]);//输出时直接调用即可
    }
    return 0;
}

 

点赞