The Triangle
时间限制:
1000 ms | 内存限制:
65535 KB 难度:
4
- 描述
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.- 输入
- Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
- 输出
- Your program is to write to standard output. The highest sum is written as an integer.
- 样例输入
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
- 样例输出
30
#include <stdio.h>
int dp[100], n, tmp, old, t, ans=0;
int main()
{
scanf("%d", &n);
for(int i=0; i<n; i++){
old=0;
for(int j=0; j<=i; j++){
scanf("%d", &tmp);
t=dp[j];
//dp[i][j]=max(dp[i-1][j-1],dp[i-1][j])+tmp
//此处进行了空间优化,old代表dp[i-1][j-1], dp[j]代表dp[i-1][j]
dp[j]=(dp[j]>old?dp[j]:old)+tmp;
if(dp[j]>ans)ans=dp[j];
old=t;
}
}
printf("%d\n", ans);
return 0;
}