甲级PAT1008 Elevator

1008 Elevator (20)(20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目要求:

电梯每上升1层需要6s ,每下降一层需要4s,每停一次需要5s

计算电梯从第0层开始,依次接每一层用户,直到接完所有的用户所需时间,最后不用回到0层

解题思路:

这是我做到现在觉得简单的都不敢写的题目。。没有坑没有技巧,就知道题目啥意思做数学题就好了。。

41 = 6*2+5+1*6+5+4*2+5

完整代码:

#include<iostream>
using namespace std;
#define maxsize 101

int main(){
	int N,i,floor=0,time=0;
	int a[maxsize];
	cin>>N;
	for(i=0;i<N;i++){
		cin>>a[i];
	}
	for(i=0;i<N;i++){
		if(a[i]>floor){
			time+=(a[i]-floor)*6;
			floor = a[i];
		}else if(a[i]<floor){
			time+=(floor-a[i])*4;
			floor = a[i];
		}
		time+=5;
	}
	cout<<time;
}

 

点赞