poj Wormholes(Bellman_ford寻找负权环)

 Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, 
F
F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: 
N
M, and 
W 

Lines 2..
M+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: a bidirectional path between 
S and 
E that requires 
T seconds to traverse. Two fields might be connected by more than one path. 

Lines 
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: A one way path from 
S to 
E that also moves the traveler back 
T seconds.

Output

Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

思路:判断是否存在负权环,Bellman_ford和spfa皆可(注意路是双向的,虫洞是单向的)

Bellman_ford代码:

#include<stdio.h>
#include<string.h>

#define maxn 600+10
#define maxv 6000+10
const int inf=0x3f3f3f3f;
int d[maxn];
struct node
{
    int u,v,w;
} E[maxv];
int n,m,s,len;

void Bellman_ford()
{
    for(int i=1; i<=n; i++)d[i]=inf;
    int flag=1,cnt=0;
    while(flag)
    {
        flag=0;
        if(++cnt>n)
        {
            printf("YES\n");
            return ;
        }
        for(int j=1; j<len; j++)
        {
            int x=E[j].u,y=E[j].v;
            if(d[y]>d[x]+E[j].w)
                d[y]=d[x]+E[j].w,flag=1;
        }
    }
    printf("NO\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&s);
        int i,x,y,z;
        len=1;
        for(i=1; i<=m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            E[len].u=x,E[len].v=y,E[len].w=z,len++;
            E[len].u=y,E[len].v=x,E[len].w=z,len++;
        }
        for(i=1; i<=s; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            E[len].u=x,E[len].v=y,E[len].w=-z,len++;
        }
        Bellman_ford();
    }
    return 0;
}

spfa代码:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

#define maxn 500+10
#define maxv 6000+10
const int inf=0x3f3f3f3f;
struct node
{
    int u,v,w;
}E[maxv];
int n,m,s,len;
int d[maxn];
int first[maxn],next[maxv];
bool inq[maxn];
int vis[maxn];

bool spfa(int st)
{
    memset(inq,0,sizeof(inq));
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)d[i]=inf;
    d[st]=0,inq[st]=1;
    queue<int>q;
    q.push(st);
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        inq[now]=0;
        for(int i=first[now];i!=-1;i=next[i])
        {
            int x=E[i].v,y=E[i].w;
            if(d[x]>d[now]+y)
            {
                d[x]=d[now]+y;
                if(!inq[x])
                {
                    inq[x]=1;
                    vis[x]++;
                    q.push(x);
                    if(vis[x]>n)
                        return true;
                }
            }
        }
        if(d[st]<0)
            return true;
    }
    return false;
}

void add_egde(int u,int v,int w)
{
    E[len].u=u,E[len].v=v,E[len].w=w;
    next[len]=first[u];
    first[u]=len++;
}
void solve()
{
    for(int i=1;i<=n;i++)
    {
        if(spfa(i))
        {
            printf("YES\n");
            return ;
        }
    }
    printf("NO\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(first,-1,sizeof(first));
        scanf("%d%d%d",&n,&m,&s);
        int u,v,w,i;
        len=1;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add_egde(u,v,w);
            add_egde(v,u,w);
        }
        for(i=1;i<=s;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add_egde(u,v,-w);
        }
        solve();
    }
    return 0;
}

ps:此题spfa比较慢,还是Bellman_ford比较好,但是测试数据好像比较弱,直接把起点看成1也能过 0.0

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/blessLZH0108/article/details/54585913
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞