poj2240——Arbitrage(Bellman-Ford算法)

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output

Case 1: Yes
Case 2: No

和poj1860类似的题,找权值为正的环路。就是节点的处理有些技巧,我这里用了哈希表

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 5005
#define mod 1000000007
using namespace std;
map<string,int> mp;
int n,m,e;
double dis[MAXN];
struct Node
{
    int beg,end;
    double r;
};
Node edge[MAXN<<1];
void add(int b,int en,double r)
{
    edge[e].beg=b;
    edge[e].end=en;
    edge[e].r=r;
    e++;
}
bool relax(int p)
{
    double t=dis[edge[p].beg]*edge[p].r;
    if(dis[edge[p].end]<t)
    {
        dis[edge[p].end]=t;
        return true;
    }
    return false;
}
bool bellman()
{
    memset(dis,0,sizeof(dis));
    dis[0]=1;
    for(int i=1; i<n; ++i)
    {
        bool flag=false;
        for(int j=0; j<e; ++j)
        {
            if(relax(j))
                flag=true;
        }
        if(dis[0]>1)
            return true;
        if(!flag)
            return false;
    }
    for(int j=0; j<e; ++j)
        if(relax(j))
            return true;
    return false;
}
int main()
{
    int cnt=1;
    while(~scanf("%d",&n)&&n)
    {
        string a,b;
        for(int i=0; i<n; ++i)
        {
            cin>>a;
            mp[a]=i;
        }
        scanf("%d",&m);
        double r;
        e=0;
        while(m--)
        {
            cin>>a>>r>>b;
            add(mp[a],mp[b],r);
        }
        if(bellman())
            printf("Case %d: Yes\n",cnt++);
        else
            printf("Case %d: No\n",cnt++);
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/blue_skyrim/article/details/52194797
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞