POJ 3169(Bellman-Ford算法,差分约束系统)

Layout 

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

 

#include <string.h>
#include <stdio.h>
#define MAX 10005
#define MAX2 1005
#define INF 0x3fffffff

int AL[MAX],BL[MAX],DL[MAX];
int AD[MAX],BD[MAX],DD[MAX];
int d[MAX2];
int N,ML,MD;

int min(int x,int y)
{
    return (x<y)?x:y;
}

void solve()
{
    int i,j,k;
    for(i=0;i<N;i++)
    {
        d[i]=INF;
    }
    d[0]=0;
    //循环k次
    for(k=0;k<N;k++)
    {
        //遍历所有的边
        for(i=0;i<N-1;i++)
        {
            if(d[i+1]<INF)
            {
                d[i]=min(d[i],d[i+1]+0);
            }
        }
        //因为A<B,且要求个头牛之间的相对位置保持不变,所以只能是BL-AL<=DL
        for(i=0;i<ML;i++)
        {
            if(d[AL[i]-1]<INF)
            {
                d[BL[i]-1]=min(d[BL[i]-1],d[AL[i]-1]+DL[i]);
            }
        }
        //更新理由同上
        for(i=0;i<MD;i++)
        {
            if(d[BD[i]-1]<INF)
            {
                d[AD[i]-1]=min(d[AD[i]-1],d[BD[i]-1]-DD[i]);
            }
        }
    }
    int res=d[N-1];
    if(d[0]<0)
    {
        res=-1;
    }
    else if(res==INF)
    {
        res=-2;
    }
    printf("%d\n",res);

}

int main()
{
    scanf("%d %d %d",&N,&ML,&MD);
    int i,j;
    for(i=0;i<ML;i++)
    {
        scanf("%d%d%d",&AL[i],&BL[i],&DL[i]);
    }
    for(i=0;i<MD;i++)
    {
        scanf("%d%d%d",&AD[i],&BD[i],&DD[i]);
    }
    solve();
    return 0;
}

 

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/chengsilin666/article/details/82467762
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞