POJ 1860 Currency Exchange【bellman_ford判断是否有正环——基础入门】

链接:

http://poj.org/problem?id=1860

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=22010#problem/A

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16244 Accepted: 5656

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

题意:



      一个城市有 N 种货币, 有 M 个兑换点
      兑换货币有一定的兑换率 r 和佣金 c
      如果货币 A 兑换 B 兑换率是 r ,佣金是 c
      那么value 个 A 可以换成 (value-c)*r 个 B
      每个兑换点能两种货币双向兑换,但是兑换比例和佣金不同
      输入时注意一下
      问:最后如果能够使得自己的钱变多,则输出 YES
            否则输出 NO


算法
:bellman_ford 判断是否有正环


思路:



      直接按照输入顺序加双向边后,套用 bellman_ford模板
      看是否有正环,如果有正环,则说明可以通过这个正环
      使得自己的钱不断增多。



补充:
关于这题为什么是判断正环就可以了,因为证明自己的钱增多,只能用初始的货币种类开始比较,也就是说如果能够增多,那么一定存在一个环可以回到初始的货币。。。

这道题目的兑换都是双向的,所以只要有正环存在,那么可以通过正环使得货币不断增加,然后 就算是起点没有包含在环中,再按照原来的路径一定能够回到起点货币,使得自己的钱增多。

code:

1860Accepted140K32MSC++2217B
/***********************************************************
A	Accepted	140 KB	0 ms	C++	1454 B
题意:一个城市有 N 种货币, 有 M 个兑换点
      兑换货币有一定的兑换率 r 和佣金 c
      如果货币 A 兑换 B 兑换率是 r ,佣金是 c
      那么value 个 A 可以换成 (value-c)*r 个 B
      每个兑换点能两种货币双向兑换,但是兑换比例和佣金不同
      输入时注意一下
      问:最后如果能够使得自己的钱变多,则输出 YES
          否则输出 NO
算法:bellman_ford 判断是否有正环
思路:直接按照输入顺序加双向边后,套用 bellman_ford模板
      看是否有正环,如果有正环,则说明可以通过这个正环
      使得自己的钱不断增多。
***********************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 110;
double d[maxn];
int n, m, index; //index 表示开始拥有的货币的编号
double money;

struct Edge{
    int u,v;
    double r,c; //r:兑换率; c:佣金; 如果拿value个u换v ,则得到的 v :(value-c)*r
}edge[maxn*2];

bool bellman_ford()
{
    for(int i = 0; i <= n; i++) d[i] = 0; //初始没有其他货币
    d[index] = money; //开始拥有的货币

    for(int i = 1; i < n; i++) //n-1 轮松弛操作
    {
        bool flag = true; //标记是否松弛
        for(int j = 0; j < m; j++)
        {
             int u = edge[j].u;
             int v = edge[j].v;
             double r = edge[j].r;
             double c = edge[j].c;

             if(d[v] < (d[u]-c)*r) //松弛【也就是走这条路,钱变多】
             {
                 d[v] = (d[u]-c)*r;
                 flag = false;
             }
        }

        if(flag) return false; //当前都无法松弛了,肯定没有正环了,直接返回
    }

    for(int i = 0; i < m; i++) //判断是否能继续松弛,如果能,就说明有正环
    {
        if(d[edge[i].v] < (d[edge[i].u] - edge[i].c)*edge[i].r)
            return true;
    }
    return false;
}

int main()
{
    while(scanf("%d%d%d%lf", &n,&m,&index,&money) != EOF)
    {
        int k = 0;
        int u,v;
        double r1,c1,r2,c2;
        for(int i = 1; i <= m; i++) //双向兑换
        {
            scanf("%d%d%lf%lf%lf%lf", &u,&v,&r1,&c1,&r2,&c2);
            edge[k].u = u;
            edge[k].v = v;
            edge[k].r = r1;
            edge[k++].c = c1;

            edge[k].u = v;
            edge[k].v = u;
            edge[k].r = r2;
            edge[k++].c = c2;
        }
        m = 2*m;
        if(bellman_ford()) printf("YES\n"); //如果有正环
        else printf("NO\n");

    }
}








    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/freezhanacmore/article/details/9713649
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞