PAT (Advanced Level) Practice 1003(Bellman-Ford)

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) – the number of cities (and the cities are numbered from 0 to N−1), M – the number of roads, C​1​​ and C​2​​ – the cities that you are currently in and that you must save, respectively. The next line contains Nintegers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

分析:用Bellman-Ford来解决问题。用一个二维set<int> pre来储存某一节点的前驱。每当更新节点对应最短距离时将对应的pre清空并将新前驱装入。当遍历到最短路径点时计算所有pre中节点的最短路径数。最后输出终点的最短路径数即可。

代码: 

#include<iostream>
#include<algorithm>
#include<vector>
#include<set>
#define MAXN 501
#define INF 0x3fffffff
using namespace std;
struct Node {
	int v;
	int d;

	Node(int _v, int _d) {
		v = _v;
		d = _d;
	}
};
vector<Node> G[MAXN];
set<int> pre[MAXN];
int d[MAXN];
int C[MAXN];
int c[MAXN];
int num[MAXN];
int N, M, C1, C2;
void BF(int start) {
	fill(d, d + MAXN, INF);
	fill(num, num + MAXN, 1);
	d[start] = 0;
	c[start] = C[start];
	for (int i = 0; i < N - 1; i++) {
		for (int u = 0; u < N; u++) {
			for (int j = 0; j < G[u].size(); j++) {
				int v = G[u][j].v;
				int dis = G[u][j].d;
				if (d[v] > d[u] + dis) {
					d[v] = d[u] + dis;
					c[v] = c[u] + C[v];
					num[v] = num[u];
					pre[v].clear();
					pre[v].insert(u);
				}else if (d[v] == d[u] + dis) {
					if (c[v] < c[u] + C[v]) {
						c[v] = c[u] + C[v];
					}
					pre[v].insert(u);
					num[v] = 0;
					for (auto it = pre[v].begin(); it != pre[v].end(); it++) {
						num[v] += num[*it];
					}
				}
			}
		}
	}
}
int main() {
	cin >> N >> M >> C1 >> C2;
	for (int i = 0; i < N; i++) {
		cin >> C[i];
	}
	for (int i = 0; i < M; i++) {
		int u, v, w;
		cin >> u >> v >> w;
		G[u].push_back(Node(v, w));
		G[v].push_back(Node(u, w));
	}
	BF(C1);
	cout << num[C2] << ' ' << c[C2] << endl;
	return 0;
}

 

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/g28_gwf/article/details/82717293
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞