hdu 1217 Arbitrage 两种算法AC代码,Floyd+Bellman-Ford 大水题一枚 注意是有向图~~

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4998    Accepted Submission(s): 2286

Problem Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

 

Input The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

 

Output For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

 

Sample Input

3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0  

Sample Output

Case 1: Yes Case 2: No  
这题主要意思就是一种货币在交换一圈后,交换回来的钱大于原来的钱,,就输出YES,否则No。
话说,我整天做这种水题有意思吗。。。
最后对字符串的处理是用的map,把map映射成数字,对应成数组的下标。
两份代码都是一次AC,这题太水了。
Bellman-Ford算法:

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <map>
#define INF 100000000
#define MAX 40 

using namespace std ;


double dis[MAX],graph[MAX][MAX];
bool Bellman_Ford(int n)
{
	for(int i = 0 ; i <= n ; ++i)
	{
		dis[i] = 0.0;
	}
	dis[0] = 1 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		for(int j = 0 ; j < n ; ++j)
		{
			for(int k = 0 ; k < n ; ++k)
			{
				if(graph[k][j] > 0.000001)
				{
					if(dis[j] < dis[k]*graph[k][j])
					{
						dis[j] = dis[k]*graph[k][j] ;
					}
				}
			}
		}
	}
	for(int i = 0 ; i < n ; ++i)
	{
		for(int j = 0 ; j < n ; ++j)
		{
			if(dis[i] < dis[j]*graph[j][i])	//只要有一个存在即可。 
			{
				return true ;
			}
		}
	}
	return false ;
}

int main()
{
	int n , m , c = 1 ; 
	double rate ;
	map<string,int> search;
	string nameA,nameB,temp ;
	while(cin>>n && n)
	{
		for(int i = 0 ; i < n ; ++i)
		{
			cin>>temp ;
			search.insert(pair<string,int>(temp,i));
		}
		cin>>m;
		memset(graph,0,sizeof(graph)) ;
		for(int j = 0 ; j < m ; ++j)
		{
			cin>>nameA>>rate>>nameB;
			int x = search[nameA] , y = search[nameB] ;
			graph[x][y] = rate ;
		}
		if(Bellman_Ford(n))
		{
			printf("Case %d: Yes\n",c++);
		}
		else
		{
			printf("Case %d: No\n",c++);
		}
		search.clear() ;
	}
	return 0 ;
}

Floyd算法:

<pre name="code" class="cpp">#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <map>
#define INF 100000000
#define MAX 40 

using namespace std ;


double graph[MAX][MAX];
bool Floyd(int n)
{
	for(int k = 0 ; k < n ; ++k)
	{
		for(int i = 0 ; i < n ; ++i)
		{
			for(int j = 0 ; j < n ; ++j)
			{
				if(graph[i][j] < graph[i][k]*graph[k][j])
					graph[i][j] = graph[i][k]*graph[k][j] ;
			}
		}
	}
	for(int i = 0 ; i < n ; ++i)
	{
		if(graph[i][i]>1)
		{
			return true ;
		}
	}
	return false ;
}

int main()
{
	int n , m , c = 1 ; 
	double rate ;
	map<string,int> search;
	string nameA,nameB,temp ;
	while(cin>>n && n)
	{
		memset(graph,0,sizeof(graph)) ;
		for(int i = 0 ; i < n ; ++i)
		{
			cin>>temp ;
			search.insert(pair<string,int>(temp,i));
			graph[i][i] = 1 ;
		}
		cin>>m;
		for(int j = 0 ; j < m ; ++j)
		{
			cin>>nameA>>rate>>nameB;
			int x = search[nameA] , y = search[nameB] ;
			graph[x][y] = rate ;
		}
		if(Floyd(n))
		{
			printf("Case %d: Yes\n",c++);
		}
		else
		{
			printf("Case %d: No\n",c++);
		}
		search.clear() ;
	}
	return 0 ;
}

与君共勉。

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/Lionel_D/article/details/43868421
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞