poj 3259 Wormholes(Bellman-Ford)

poj 3259 Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

题目大意:一个人在宇宙中旅行,有两种路径可以走。第一种是普通的宇宙,是双向的,并且耗时。第二种是虫洞,单向的,并且可以使时间倒流。现在问在宇宙中是否有一条路,可以使得男主通过虫洞返回出发前的时间。

解题思路:读入普通路径的时候,记得双向。读入虫洞路径的时候记得是单向的,并且权值为负。图建完了,就是BF判断是否有负环。有负环则可以穿越回过去,否则不行。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <queue>
using namespace std;

const int INF = 0x3f3f3f3f;
const int M = 6000;
const int N = 600;
typedef long long ll;
int n, m, w, s;
struct Edge {  
    int from, to, dist;  
};  
vector<Edge> edges;  

int vis[N], d[N], rec[N];
int L[N];
void init() {  
    for (int i = 0; i <= n; i++) vis[i] = 0;
    edges.clear();  
}  

void addEdge(int from, int to, int dist) {  
    edges.push_back((Edge){from, to, dist});  
}
void input() {
    scanf("%d %d %d", &n, &m, &w);
    int a, b, c;
    for (int i = 0; i < m; i++) {
        scanf("%d %d %d", &a, &b, &c);  
        addEdge(a, b, c);
        addEdge(b, a, c);
    }
    for (int i = 0; i < w; i++) {
        scanf("%d %d %d", &a, &b, &c);  
        addEdge(a, b, -c);
    }
}

int BF() {
    for (int i = 0; i < n; i++) d[i] = INF; 
    d[0] = 0;
    int a, b;
    for (int i = 0; i < n - 1; i++) { //迭代n - 1次
        for (int j = 0; j < edges.size(); j++) { //检查每条边
            a = edges[j].from, b = edges[j].to;
            if (d[a] < INF) {
                d[b] = min(d[a] + edges[j].dist, d[b]); //松弛
            }
        }
    }
    for (int i = 0; i < edges.size(); i++) { //若n - 1次更新后,还能更新,则有负环
        a = edges[i].from, b = edges[i].to;
        if (d[b] > d[a] + edges[i].dist) {
            return 1;
        }
    }
    return 0;
}
int main() {
    int T;
    scanf("%d", &T);
    while (T--) {
        int A, B;
        init();
        input();
        if (BF()) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/llx523113241/article/details/47067669
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞