Arbitrage POJ2240 bellman_ford

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21566 Accepted: 9185

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

这一题和POJ1860挺像的,用bellman_ford水一水就可以了。不过还是有要注意的地方。。。。

1.在if判断句中,得先把值赋给一个变量之后再做比较,否则。。。只有二进制知道哪里出了问题。。。。。

2.之所以wa了三次,浪费了一个小时,是因为。。。。注意输出只有第一位字母是大写。。。。。

大概思路就是,对于每个点用一次bellman_ford,看有无与其相连的正圈,如果有就是yes。。。

代码如下:

<span style="font-size:24px;">#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<string>
using namespace std;
map<string,int>ma;
struct My
{
    int from,to;
    double hui;
} cun[950];

double d[35];
 int  n,m;double num;
bool bellman_ford(int s)
{
    memset(d,0,sizeof(d));
    d[s]=10;
for(int i=1;i<=n;i++)
{
    for(int j=1;j<=m;j++)
    {
     My mm=cun[j];
     double aa=d[mm.from]*mm.hui;
        if(d[mm.to]<aa)
        {
            d[mm.to]=d[mm.from]*mm.hui;
            if(i==n){
                    //cout<<i<<"   "<<mm.from<<"   "<<mm.to<<"    "<<d[mm.to]<<endl;
                    return true;}
        }
    }

}
return false;
}
int main()
{
    string str,str1;
    int icase=1;
    while(cin>>n&&n)
    {
        ma.clear();memset(cun,0,sizeof(cun));
        for(int i=1; i<=n; i++)
        {
            cin>>str;
            ma[str]=i;
        }
        cin>>m;
        for(int i=1; i<=m; i++)
        {
            cin>>str>>num>>str1;
            cun[i].from=ma[str];
            cun[i].to=ma[str1];
            cun[i].hui=num;
        }
 bool flag=false;
        for(int i=1; i<=n; i++)
        {
        flag=bellman_ford(i);
        if(flag)break;
        }
         cout<<"Case "<<icase++<<": ";
if(flag)cout<<"Yes"<<endl;
else cout<<"No"<<endl;
    }
    return 0;
}
</span>


    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/lwgkzl/article/details/53102396
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞