hdu1874 畅通工程续 Bellman-Ford算法SPFA 算法

连接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

Problem Description 某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。  

Input 本题目包含多组数据,请处理到文件结束。

每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。

接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。

再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。  

Output 对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

 

Sample Input

3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2  

Sample Output

2 -1

思路:用Dijkstra算法做了一遍,又学了Bellman-Ford算法,再写一遍。。。用队列,不断的将起点s的邻接点加入队列,取出,不断的进行松弛操作,直到队列为空
如果一个结点被加入队列超过n-1次,那么显然图中有负环

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <queue>
//不断的将s的邻接点加入队列,取出不断的进行松弛操作,直到队列为空
//如果一个结点被加入队列超过n-1次,那么显然图中有负环
#define Min(x,y) ( (x) < (y) ? (x) : (y) )
using namespace std;
const int maxn = 205;
const int INF = 0xffffff;
struct Node
{
    int vex,weight;
    Node(int _vex = 0,int _weight = 0) : vex(_vex),weight(_weight){}
};
vector<Node> G[maxn];
int dist[maxn],cnt[maxn],n,m;
bool inqueue[maxn];

void Init()
{
    for(int i = 0 ; i < maxn ; ++i){
        G[i].clear();
        dist[i] = INF;
    }
}
int SPFA(int s,int e)
{
    int v1,v2,weight;
    queue<int> Q;
    memset(inqueue,false,sizeof(inqueue));//标记是否在队列中
    memset(cnt,0,sizeof(cnt));//加入队列的次数
    dist[s] = 0;
    Q.push(s);//起点加入队列
    inqueue[s] = true;//标记
    while(!Q.empty()){
        v1 = Q.front();
        Q.pop();
        inqueue[v1] = false;//取消标记
        for(int i = 0 ; i < G[v1].size() ; ++i){//搜索v1的链表
            v2 = G[v1][i].vex;
            weight = G[v1][i].weight;
            if(dist[v2] > dist[v1] + weight){ //松弛操作
                dist[v2] = dist[v1] + weight;
                if(inqueue[v2] == false){ //再次加入队列
                    inqueue[v2] = true;
                    //cnt[v2]++; 判负环
                    //if(cnt[v2] > n) return -1;
                    Q.push(v2);
                }
            }
        }
    }
    return dist[e];
}
int main()
{

    int v1,v2,weight,s,e;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        Init();
        for(int i = 0 ; i < m ; i++){
            scanf("%d%d%d",&v1,&v2,&weight);
            G[v1].push_back(Node(v2,weight));
            G[v2].push_back(Node(v1,weight));
        }
        scanf("%d%d",&s,&e);
        int ans = SPFA(s,e);
        if(ans == INF)
            printf("%d\n",-1);
        else
            printf("%d\n",ans);
    }
    return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/migu77777/article/details/52106659
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞