I - Arbitrage(Bellman-Ford算法判正环)

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No

题解:

Bellman-Ford算法判正环。
除了起始点的dist其他点的dist都设为0即可。
当s到其他某点的距离能不断变大时,说明存在最大路径

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <map>
#include <vector>
#include <string>
using namespace std;

const int maxn = 40;
double dist[maxn];

struct Edge
{
    int u;
    int v;
    double rt;
    Edge(int _u,int _v,double _rt):u(_u),v(_v),rt(_rt){}
};

vector<Edge> E;

bool BellmanFord(int start,int n)
{
     memset(dist,0,sizeof(dist));
     dist[start]=1;

     for(int i=1;i<n;i++)
     {
         bool flag = false;
         for(int j=0;j<E.size();j++)
         {
             int u = E[j].u;
             int v = E[j].v;
             double rt = E[j].rt;
             if(dist[v]<dist[u]*rt)
              {
                  dist[v]=dist[u]*rt;
                  flag = true;
              }
         }
         if(!flag) return false;
     }

     for(int i=0;i<E.size();i++)
     {
         if(dist[E[i].v]<dist[E[i].u]*E[i].rt)
         {
             return true;
         }
     }
     return false;
}

int n;
map<string,int> m;


int main()
{
    int cas=1;
    string s;
    while(cin>>n&&n)
    {
      for(int i=0;i<n;i++)
      {
          cin>>s;
          m[s]=i;
      }

      int num;
      cin>>num;
      string st,ed;
      double r;
      for(int i=0;i<num;i++)
      {
          cin>>st>>r>>ed;
          E.push_back(Edge(m[st],m[ed],r));
      }

      printf("Case %d: ",cas++);

      for(int i=0;i<n;i++)
      {
          if(BellmanFord(i,n))
          {
              cout<<"Yes"<<endl;
              break;
          }
          else if(i==n-1)
          {
              cout<<"No"<<endl;
          }
      }

      E.clear();
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/q451792269/article/details/78500307
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞