POJ 3259 Wormholes (Bellman-Ford判断负环)

题目

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1N500) fields conveniently numbered 1…N , M (1M2500) paths, and W (1W200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1F5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1 : A single integer, F . F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N , M , and W

Lines 2..M+1 of each farm: Three space-separated numbers (S,E,T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.

Lines M+2..M+W+1 of each farm: Three space-separated numbers (S,E,T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F : For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1 , FJ cannot travel back in time.

For farm 2 , FJ could travel back in time by the cycle 1231 , arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意

有一个人,他喜欢时间旅行,现在有一些虫洞,可以回到过去,现在有 n 个点, m 条边,代表现在可以走的通路,比如从 a b 和从 b a 需要花费 c 时间,现在在地上出现了 w 个虫洞,虫洞的意义就是你从 a b 话费的时间是 c (时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前。现在让你判断他能不能回到从前。

思路

题目的数据给出了每个点的坐标,这样就可以构成一张图,用 BellmanFord 算法判断该图中是否存在负环,如果存在,输出“YES”,否则输出“NO”。题目数据比较水,没有考虑重边的情况。。。可以套模板

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<set>
#include<map>
#include<cstdlib>
#include<functional>
#include<climits>
#include<cctype>
#include<iomanip>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define mod 1e9+7
#define clr(a,x) memset(a,x,sizeof(a))
const double eps = 1e-6;
const int MAX_N=10000;
const int MAX_E=10000;
int From[MAX_E],To[MAX_E],W[MAX_E];
int dis[MAX_N],tot;
void init()
{
    tot=0;
}
void add_edge(int u,int v,int d)
{
    From[tot]=u;
    To[tot]=v;
    W[tot++]=d;
}
bool Bellman_ford(int s,int n)
{
    clr(dis,0x3f);
    dis[s]=0;
    for(int k=0;k<n-1;k++)
    {
        bool relaxed=0;
        for(int i=0;i<tot;i++)
        {
            int x=From[i],y=To[i];
            if(dis[y]>dis[x]+W[i])
            {
                dis[y]=dis[x]+W[i];
                relaxed=1;
            }
        }
        if(!relaxed)
            break;
    }
    for(int i=0;i<tot;i++)
        if(dis[To[i]]>dis[From[i]]+W[i])
            return 1;
    return 0;
}
int main()
{
    int f,n,m,t,u,v,w;
    cin>>f;
    while(f--)
    {
        int num=0;
        init();
        cin>>n>>m>>t;
//*************************************建图
        for(int i=0;i<m;i++)
        {
            cin>>u>>v>>w;
            add_edge(u,v,w);
            add_edge(v,u,w);
            num+=2; //记录边的个数
        }                       
        for(int i=0;i<t;i++)
        {
            cin>>u>>v>>w;
            add_edge(u,v,-w);
        }
//*************************************建图
        bool ans=Bellman_ford(1,num);
        if(ans)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_38361686/article/details/76735829
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞